Sustainability Navigation

TV CAM HD cannot connect to internet

Answered

Comments

144 comments

  • TVcamHD_user
    Hi there \r\n \r\nYes, the fix that I provided is still working for me. \r\n \r\nYou have opened up an OpenDNS Umbrella account, not an OpenDNS Home account. Please follow the instructions of any guides that people have provided here carefully. Please post your outcome, whether it works or not for you. \r\n \r\nRegards \r\nTVcamHD_user
    0
    Comment actions Permalink
  • Mike Copros
    It looks like the problem for the not working "ping" to www.skype.com[http://www.skype.com] and the firmware from 2013 that adds the HTTP Post request as a fallback will all be in vain when now Microsoft ist shutting down the support for "Skype on TV" I am not sure why this Android embedded device is not able to use the enduser Skype binary for android devices and needs to be turned into a pile of expensive scrap hardware. Is there really no official support from Logitech for this product anymore ? Currently I am evaluating one of the webcam for private use but on the brink of these devices just being abandoned by Logitech this is not feaisble.
    0
    Comment actions Permalink
  • batyan
    One more time neither microsoft nor logitech dont care about customers ( only money ) espesialy old people. I never buy they product anymore and become google customer. **bleep** them.
    0
    Comment actions Permalink
  • Pedro29
    Attention pour les solutions à base de changement de DNS pour ceux qui sont équipés de LIVEBOX avec téléphonie sur IP. Le changement de DNS provoquerait l'arrêt de la téléphonie.
    0
    Comment actions Permalink
  • John Bailey
    Many thanks to TVcamHD_user & SaverioB for the DNS solution to enable my defunct TC Cam HD to connect to Skype again.  I am a New Zealand owner of the TV Cam HD & purchased the unit in March 2013 specifically on Logitech's claim that it could enable Skyping without the need for a PC or Smart TV.  For the best part of 3 years, the device has provided excellent service.   Then in early May 2016, I along with many other loyal users, suddenly found that the device could no longer connect to the Internet.  I spent a lot of time checking connections, settings etc as advised by the on-screen warning without success before researching the issue in a variety of forums.   Opening a complaint with Logitech NZ provided a response that Logitech was aware of the failure of its TV Cam HD & would revert once an update from its internal team had been received.  This update turned out to be the now standard advice regarding warranty support but tough luck if your device was no longer covered.   With no other solution to turn this worthless device back in to a useable Skype camera but not wanting to undertake drastic reconfiguration of my router's IP addresses, I eventually found your solution.  I followed the instructions & now have a working camera once again.   I feel very let down by Logitech &, despite the fact that I have purchased many of its devices in the past (web cams, Harmony One remote, mice, headsets, speakers) I no longer have the trust that Logitech cares about its customers once a sale is made.   Again, many thanks for sharing your solution.
    0
    Comment actions Permalink
  • TVcamHD_user
    Hi TV cam users   Here is an updated version of the guide I provided earlier. It contains extra information/comments that will hopefully help other people feel more comfortable changing their settings to get their TV cam working (and also keep working due to the possibility of your router's dynamic IP address changing!). I ran into this dynamic IP address problem last night, but the TV cam is again up and running.       I have managed to get the TV cam working with the instructions from SaverioB.   Here is what i did from a computer connected to my home network, which is also where my TV cam is connected as well.   1) You need to change your router settings, so log on to it, usually through your browser. 2) Change your router's DNS settings from what they are (usually obtained from your internet provider) to those from OpenDNS.com, which are as follows: Primary DNS                       208.67.222.222 Secondary DNS                 208.67.220.220 3)Save those settings and reboot the router. If you cannot change/save your DNS settings, then this workaround will not work for you. This might be the case for people who have modems/routers from their internet provider that has some settings not able to be changed. @zarzash? has a workaround that might work for you instead. 4)Sign up for a OpenDNS Home account https://signup.opendns.com/homefree/[https://signup.opendns.com/homefree/] and enter the relevant details. You will need to click the link in the email sent to your email account to confirm the creation of the OpenDNS Home account 5)Sign into OpenDNS on https://login.opendns.com/[https://login.opendns.com/] 6)Click on "Add a network" and you should see an IP address that your computer/Tv cam connects to. Add this network and you can give it a name if you want. Since most internet providers give IP address dynamically, keep this option checked. I didn't download the additional software. Download the extra software, but do not open it in the meantime. \r\n 7)Click on the IP address that you have just set up. Ignore the Web Content Filtering part, you are only interested in the "Manage individual domains". Type www.skype.com[http://www.skype.com] into the box and  "Always Block" before clicking "Add domain". Click on "Add domain" again. Click on "confirm". 8)Sign out of OpenDNS. Wait a couple of minutes before unplugging/plugging the power to your TV cam and hopefully it should work from now on. But we haven't quite finished yet! 9)For the vast majority of TV cam users that use it at home, and whether you know this or not, but it is most likely that your router has a dynamic IP address that has been assigned by your internet provider. Because this workaround depends on your OpenDNS settings having the same dynamic IP address, they must be the same for the TV cam to keep working. So if your dynamic IP changes, which is something you have very little control over, then the OpenDNS settings will not match, and then your TV cam will not work anymore. There are several ways around this, depending on your needs and skill level.   A)Go to OpenDNS again https://login.opendns.com[https://login.opendns.com/] and manually refresh/type the new IP network address so that your OpenDNS settings again matches your recently changed dynamic IP address. The level of practicality of this method will depend on largely how you use your TV cam. If you only make calls, or make a few calls to friends and family during the week, then this may be the most practical since if your TV cam doesn't work when you want it to work, you just have to do this and then refresh your network connections on the TV cam to get it working again.  B)You can use the downloaded software and run it on your computer to automatically keep telling OpenDNS your dynamic IP address, so it keeps OpenDNS informed of any changes. Enter your OpenDNS Home account details when required and if you like, select "Run hidden" (in settings). This should make your TV cam work always online, but it requires this software (and therefore a computer) to be constantly on to perform the announcement of your new dynamic ip address to OpenDNS when it does change. C)Depending on your brand of router, you may be able to announce your dynamic IP address changes to OpenDNS at the router level (so that your TV cam will always be online and requires no further assistance once you set it up). This either requires a very good understanding of your router from yourself, or the router company or other more tech savvy people providing guides for you to show the changes in settings through google.   Note: With this workaround, you will not be able to look at webpages from www.skype.com.[http://www.skype.com.] From my limited testing, it doesn't affect the skype program that i use independently on my computer.   Logitech still needs to provide a firmware update to stop workarounds like this.   Hope this information works for you too TVcamHD_user   EDITED: Correct link for OpenDNS Home acccount
    0
    Comment actions Permalink
  • batyan
    hi there. Like i stated before when anybody created Open DNS ( Umbrela ) account it says you have trial period of 14 days? So I presume after that period I have to pay for using it? And by the way link ( https://signup.opendns.com/homefree/)[https://signup.opendns.com/homefree/%29,] doesnt work? any help. thx.    
    0
    Comment actions Permalink
  • TVcamHD_user
    Hi batyan \r\n \r\n1) The Umbrella account does have a trial period of 14 days, and probably will cost some money to operate afterwards. But I have never suggested to people to create an OpenDNS Umbrella account. That is something you have done yourself. I have suggested people should create an OpenDNS Home account, which is different to the OpenDNS Umbrella account. The Home account is free and does not have a trial period. . \r\n \r\n2)The link has now been correctly edited. Thanks for the proofreading!   Regards TVcamHD_user
    0
    Comment actions Permalink
  • CustomerIsKing
    Hi TVcamHD_user and SaverioB, I've just registered to this forum to tell you: T H A N K   Y O U   S O   M U C H  for your valuable support. I would have expected such effort from the supplier who in my opinion is loosing face towards all of us. His deafening silence does not fix 250€ tv cam brought from south korea to be used in Italy to let my mother watch my 2years old daughter growing up 2000km faraway from her. I managed to let the tv cam work following your detailed instructions. But at the moment the cam is in my place and without opendns no way. I confirm the latest firmware doesn't fix the problem. I am afraid I cannot manage remotely the cam working at my parents place; they don't have a pc and they are no able to use it, otherwise I wouldn't buy the tv cam!   Dear Supplier, show to your Customers you really care of them. I remember you that Customer is the King and is who pays your salary. Face your responsibilities without hiding on others decisions and provide a solution.   Regards
    0
    Comment actions Permalink
  • geowang
    Recently my grandpa reported the Logitech Skype TV cam failing to connect.   It seems there has been little consideration for the user base that rely on these devices. Please Logitech provide a firmware fix as I cannot expect my 90+yo grandfather to learn to use a mobile/tablet especially when I'm across the water on another continent.
    0
    Comment actions Permalink
  • gb5757870
    Thanks so much for sharing. Confirmed that worked for me too
    0
    Comment actions Permalink
  • damljas
    Hey zarzash,   thanks for the tip on using pocket router! Can you please provide more details what we have to do once we have a pocket router [set as a client] connected to the logitech skype tv cam? Also, I understand that the actual problem is that the cam unit can not reach [ping] www.skype.com[http://www.skype.com] when it checks for internet connection [thus ending up in an endless loop]. If that is the case, why did you have to block all the sites you mentioned in your post?   Greatly appreciated!!!!!!!!    
    0
    Comment actions Permalink
  • zarzash
    @damljas?   I have posted few replies in thisother thread with some indication about what I did. Even if the actual setting can depend on your home configuration, i hope they will help you: Unable to connect to the Internet when attempting to logging to   I was in a testing situation where the trick did not seam to work correctly. Thus I looked at the DNS logs and spotted all connectiong going to any site related to skype and blocked them. Also being outside of the US, I was not sure what skype site my fw was pinging.   Currently I am only blocking the www.skype.xxx[http://www.skype.xxx] domains.
    0
    Comment actions Permalink
  • damljas
    @zarzash?   Thanks for the quick reply!!!!   I got my Logitech Skype TV Cam to work!!!!!!!!!!! I will post again with info regarding my home network setup/settings but for now here is what I did. 1. Logged on to my DIR-880L router 2. Under Features / Website Filter I added a rule www.skype.com[http://www.skype.com] [DENY client access to ONLY these sites] 3. Save the applied rule 4. Rebooted the router   10-15 minutes after the router rebooted, I turned on my Logitech Skype TV Cam and I could see it was checking the internet connection ... it took a minute or two and then it showed it was logging me in!!!! I was able to skype my sis at her home ... Not sure why this router website filter rule worked but for now ... I dont care .  
    0
    Comment actions Permalink
  • Steebmo86
    This is very interesting.   Maybe when the camera is requesting skype.com from your router, the router is still sending a reply to the ping request from the camera in the form of a "This site has been blocked, contact your network administrator" HTML page?   Regardless, I'm glad it works, I might need to give this a try!
    0
    Comment actions Permalink
  • HD Boo
    Thanks, damljas.   This is an important information. The way  TVcamHD_user showed us using the OpenDNS worked for me. It solved my side.   TV CAM HD cannot connect to internet   The problem remains still in my parent side. She is over 80 with no PC or tablet living far from me. I constructed a relatives' network using 5 TV CAMs a few year ago. Two of them are for elders.. I need a complete solution on the dynamic IP without any maintenance once it's installed.   Based on damljas' information, I tried on my Buffelo WiFi router AirStation WHR-G301N to block the IP addresses of the skype from LAN to WAN. It has the IP filtering function which returns a rejection packet to the sourse. At lest its manual says so. It effectively blocked the packet to the skype. BUT the TV CAM was still searching the internet connection   I don't know the detail but at least it meant the rejection packet the router returned didn't match the TV CAM's need.   One stupied trial I made was that I connected two Buffalo routers in serial with the "same" LAN IP address. Of course it caused a network confusion. But when I connected the TV CAM to the end router wirelessly, it worked!! It might return some error packet which matched the TV CAM.  I haven't checked the connection stability of the TV CAM. At least I recognized it caused a confusion on my home LAN with several wireless connections. So, I declined this way.   Anyway, from all the information I got on this board, i guess the easiest solution for now for the eldests is to replace the router  to the one damljas is using. I don't know if DIR-880L is the only one which filters the www.skype.com[http://www.skype.com] effectively to mock the TV CAM. The other D-Link routers or other models may have the same function. I need a cheaper solution.   If anyone tried the similar way on the router and suceeded to mock the TV CAM, please post the model of your router. It'll be a great help for many.   At leastI know  the IP filtering on my Buffalo router didn't work.   Thanks.
    0
    Comment actions Permalink
  • zarzash
    Before your purchase a new router, check if it is not simpler or cheaper to buy a different camera.   Apparently the TelyHD Skype Web Cam work without the ping issue (which also prooves that the problem is with Logitech and not Microsoft). This camera costs about 125$ on amazon. So may worth the switch depending of your individual situation.
    0
    Comment actions Permalink
  • HD Boo
    Thank you for the suggestion. Yes, it's one solution.   After the previous posting, I made some progress. I have  two backup routers unused ; FON 2405E & PLANEX MZK-RP150N. I tried to change the LAN IP address of the router to the Skype IP address. In my case, the IP was 23.102.255.237.  It WORKED for both routers!! My  Buffalo AirStation didn't accept the IP address above. It was my problem. I needed to choose "Router" mode for the PLANEX.There was no choice for the FON. DHCP was ON for both cases.   From the information on this and the other boards, the other possible Skype IP addresses are    40.115.34.155    104.40.50.126     40.121.80.200 It may depend on the HD CAM you have. At least for my two CAMs at hand,  the above IP was effective. I'm really glad Yes, I've read some post that told the use of two routers. But I couldn't find the detail. Maybe he told about this.   [ Update : You don't need two routers.  You should connect an additional router in which you set the Skype IP address in the LAN side only if you don't want to change the IP address in your existing home network. I think for the elders who don't use PCs or some gudgets other than the HD CAM, LAN IP address change is not a matter. So, if their router accepts the change to the Skype IP address in the LAN side, I thihk it's an enough solution for them. ]   Now, if I can replace my parent's router somehow with either of them, I believe the problem is solved! ( at least temporarily until Microsoft changes the Skype something more    )   [Update : I decided to replace the Buffalo router in my parent's home with the FON router. It's obsolete and slow, but still enough for the Skype.]   There must be many routers which accept the Skype IP address in the LAN side. My main router Buffalo didn't... PLANEX could be promising.   Please try it if you haven't do it.  We can get a cheap used router on eBay.    
    0
    Comment actions Permalink
  • Johnains
    Many thanks Damljas. Tried this with my Vodafone Connect router and set the block for www.skype.com[http://www.skype.com] in the Firewall URL filtering and it works!!!   Can't believe Logitech haven't suggested this. Have been arguing with them for days and they even agreed to replace the cameras, I have three of them, two with my daughters, with 3 C920s. TheTV HDs are out of warranty but I don't consider this to be a warranty issue as the cameras are not faulty themselves, it is their design and firmware that are obsolete. Just need to get my daughters cameras working now!   This has certainly shaken my faith in the company and I shall think very carefully before buying any more of their products.   Thanks again
    0
    Comment actions Permalink
  • mjlewis
    Hi all,   Here is a step by step tutorial I put together using a $15 mini router to fix the pinging issue.   You can set up two of these in identical fashions, and then ship one to grandma/grandpa, and they could set it up without much trouble.  You will need to make sure you figure out and use the right Skype IP address for grandma/grandpa's region.   https://drive.google.com/file/d/0Bw-ltHgkxqy0bmVCWVVNNjkxRDA/view?usp=sharing[https://drive.google.com/file/d/0Bw-ltHgkxqy0bmVCWVVNNjkxRDA/view?usp=sharing]      
    0
    Comment actions Permalink
  • suiroutard
    Hello,   Yes it is true. Logitech offers a C920 Webcam instead of uploading a new firmware. If you accept the offer you have to cut the cables provided with the camera and send them pictures of it plus a written note promising not to use the camera. Sad !   Hope you find a resolution for yourself.   Regards   Daniel
    0
    Comment actions Permalink
  • DooqBara1007
    My fix is the following: \r\n \r\nConfirmed to work. \r\nConnect on laptop/pc, and ping www.skype.com[http://www.skype.com] \r\nMake a notation of the IP Address. \r\n \r\nIn my case: 104.40.50.126, then set this is as the home / gateway address for LAN Router. \r\nI have ASUS Router and it was in LAN Settings page. \r\n \r\nReset Skype Camera, and it should connect. \r\nReset any IP Devices so that IP Addresses propgae as expected \r\n \r\nFeel free to reach out dooqsavings@gmail.com if you keep having issues. -Dooq ( I hope logitech fixes this.....)
    0
    Comment actions Permalink
  • darrenstewart77
    I'm with Sky Broadband, and they have their sky hub router locked down so that the DNS settings cannot be changed. Am I right in saying then that I need to buy a new router? Can anyone suggest a suitable router in the UK that allows DNS settings to be changed? I'm ideally looking at something simple, as like a lot of other people, this fix is for my parents who want to see their grandson growing up in Australia, and it needs to be easy to fix. I heard some mention of 'pocket router'? Thanks in advance.
    0
    Comment actions Permalink
  • SlayerGP
    damljas wrote: \r\n@zarzash   Thanks for the quick reply!!!!   I got my Logitech Skype TV Cam to work!!!!!!!!!!! I will post again with info regarding my home network setup/settings but for now here is what I did. 1. Logged on to my DIR-880L router 2. Under Features / Website Filter I added a rule www.skype.com[http://www.skype.com] [DENY client access to ONLY these sites] 3. Save the applied rule 4. Rebooted the router   10-15 minutes after the router rebooted, I turned on my Logitech Skype TV Cam and I could see it was checking the internet connection ... it took a minute or two and then it showed it was logging me in!!!! I was able to skype my sis at her home ... Not sure why this router website filter rule worked but for now ... I dont care .   Hoping to save everyone else many hours of pain. I can confirm that this works.    In some routers, these filters may be in your firewall section.   BTW using this method, the skype domain isn't blocked as it would be using the DNS method.   For example, in my Billion router, I went to URL Filter and then selected Domain Filtering. Maybe look for something similar in yours...    
    0
    Comment actions Permalink
  • Jim-R
    Tried your suggestion using using each of ther proposed entries: (Note without the "  " shown below) I'm using Windows 10 Pro and I shared my laptop internet connection.   "127.0.0.1 173.194.78.104 www.skype.com [http://www.skype.com] # www.google.com[http://www.google.com] IP"   and   "127.0.0.1 www.skype.com[http://www.skype.com]" "127.0.0.1 www.google.com[http://www.google.com]"   Before and after trying to connect to the internet, I did a ping from the laptop as a test and both entry sets succeeded.   Here is my host.ics file for the first entry above: 127.0.0.1 173.194.78.104 www.skype.com  [http://www.skype.com]   ## Copyrught (c) 1993-2001 Microsoft Corp. # # This file has been automatically generated for use by Microsoft Internet # Connection Sharing.  It contains the mapping of IP addresses to host names # for the home network.  Please do not make changers to ther HOST>ICS file. # Any changes may result in a loss of connectivity between machines on the # local network. #   192.168.137.65 TVcambcf22971f89e5f79.mshome.net  #  2016 7 5 8 19 32 33 952 192.168.137.1 Vostro-3350.mshome.net  #  2021 6 3 30 19 57 44 533 127.0.0.1 173.194.78.104 www.skype.com [http://www.skype.com] #  Google.com IP   I also tried using the second entry set. 127.0.0.1 www.skype.com[http://www.skype.com] 127.0.0.1 www.google.com[http://www.google.com]"   No Joy!   Need Help.
    0
    Comment actions Permalink
  • Brett9035
    Hello, I am not clear on why a change in the router DNS would make the camera ping itself...the DNS servers translate the IP addresses. How does the rest of the internet continue to work correctly if we change one if the DNS? How do we make the camera to specifically ping a different server when it tries to connect to skype.com?
    0
    Comment actions Permalink
  • zarzash
    I am not sure who tested and marked the reply pretending the FW 1.6.214 fixes the issue. I can say that it does NOT solve the problem over the Wifi connection of the camera. The connection via a router that blocks routing to www.skype.com via OpenDNS does work.
    0
    Comment actions Permalink
  • Brett9035
    Hi zarzash, thanks for the reply. Let me see I understand how to use solve this connectivity problem: I need to go into my router settings and change the DNS servers IP address. There are many options (OpenDNS, Public Google, etc.). But that should not solve the problem since when the camera will ping www.skype.com and any DNS will simply translate the URL to the actual skype IP and the camera won't work. Maybe I need to: a) either change the primary DNS to some server IP address so when the camera pings skype it is actually pinging the server and receives a positive reply. But in that case even all other URL won't work because the primary DNS won't work for them either. b) Is there a place, in the router settings, where I can block the routing to a specific URL, in this case www.skype.com? Why does it matter if the DNS are OpenDNS or something else? I have a MotorolaN300 Wifi router and I am not sure I saw a place where to block certain URLs. If the URL is blocked, the camera should not receive a ping reply back. Wouldn't that make the camera not work either? Thanks!
    0
    Comment actions Permalink
  • Brett9035
    Option ) may be ok if I make sure the DNS IP on all the network devices are correct. The devices will rely on their DNS and not on the router primary DNS...
    0
    Comment actions Permalink
  • zarzash
    Hi Brett9035, the questions you are asking have been answered. You need to read around in this forum as it is not convenient to repeat the same details many times. The way a device communicate with www.skype.com is that it asks is DNS what is the IP of this host. So the idea is to provide to the Skype camera another DNS to talk to. Depending on your home setting this is either you existing router, or like in my case an extra dedicate router for just the skype camera. Once this is made possible, then you have the choise. In my case, I configure this extra dedicated router to use OpenDNS as DNS. Then on my OpenDNS configuration I block www.skype.com. In fact OpenDNS returns the IP of the main gateway as IP. In this case, when my skype camera wanted to ping www.skype.com It asks its DNS (here OpenDNS) the IP to use. OpenDNS return the IP of the main gateway which is my main router and which does reply to the ping. So the skype camera is happy. Why OpenDNS? because in my configuration I have no other way to influence the way names are resolved. Without pretending to give a networking course in a nutshell I hope this helped to clarify the rational behind this obscure gymnastic we are trying to do.
    0
    Comment actions Permalink

Please sign in to leave a comment.