Sustainability Navigation

Update to accessing Harmony Hub’s local API via XMPP

Comments

40 comments

  • Dean Rispin

    Thanks for giving us advanced notice. Much better community support!

    0
    Comment actions Permalink
  • Joe Roberts

    This seems a little extreme: "By enabling the XMPP connection ... enabling this connection ... you void all warranty"

    I understand that you are not liable if I have an insecure network and someone hacks and bricks my hub, but surely you should still cover any hardware faults if I am not hacked? What about the remotes linked to the hubs?

     

    0
    Comment actions Permalink
  • Dave Leiner

    Thanks for the heads up! FYI, I see the option to disable XMPP but the hub firmware is still at 4.15.210.

    0
    Comment actions Permalink
  • Sander Doppenberg

    Still haven't received the update! Waiting patiently..

    0
    Comment actions Permalink
  • Jürgen Greil

    I also see the XMPP option in the iPhone App, but still at FW 4.15.210.

    Is the 250 update not released yet?

    0
    Comment actions Permalink
  • Joe Roberts

    @Jürgen Greil? Where exactly is this option in the iOS app? I have app version 5.6, but I can't find the XMPP option. Which menu item is it under? Thanks

    0
    Comment actions Permalink
  • Jürgen Greil

    From your Harmony app, go to: Menu > Harmony Setup > Add/Edit Devices & Activities > Remote & Hub > Enable XMPP

    0
    Comment actions Permalink
  • Joe Roberts

    @Jürgen Greil? Thanks

    0
    Comment actions Permalink
  • Frank Thompson

    @William Wong?  @Joe Roberts? is correct. That seems like some very extreme warnings. I appreciate you guys adding XMPP back in, but it would be nice if Logitech actually embraced our community a bit more and worked with the integration developers to give everyone a secure system which allows users to integrated their hubs into their Home Automation systems

    0
    Comment actions Permalink
  • Jon Hanford

    @Joe Roberts? @Frank Thompson? as per the Magnuson-Moss Warranty Act of 1975 manufacturers can't void a hardware warranty simply for software modifications, unless the software modification is directly the cause of hardware failure.

     

    I surmise the copy of that disclaimer is their legal team making it completely explicit that they aren't going to provide support for this feature beyond including it.

     

    And hey - I'm fine with that. The reality is some users don't need it, and opening it up without basic network security could be a security issue. It's a completely unsecured API, I get it. (As long as the port isn't accessible to the WAN, there's no issue unless a bad actor is already on your network.) In a perfect world they work with the HA communities to provide a secure system, but the implemented solution is a very welcome compromise.

     

    I created the first thread on the API closure here (😇) and I've been saying from the beginning, the most straightforward thing to do to ensure security and keep power users happy is to add an option to turn on XMPP with a disclaimer, but leave disabled by default. So from my position, I'm exeedingly glad they did exactly that - and honestly went the extra mile by providing the dev firmware so that people could get up and running in the interim.

     

    SO, my well earned thank you goes out to the Harmony team - thanks for announcing this change in advance as well, (and I hope you'll duly announce any other changes to the API before they're rolled out in the future. 😬 )

    0
    Comment actions Permalink
  • Frank Thompson

    @Jon Hanford?  I agree with everything you said. I just wish these bigger corps would get more involved with this community of not only enthusiastic users, but also tend to be influencers to their friends about this type of technology.

    0
    Comment actions Permalink
  • Jürgen Greil

    New FW 4.15.250 is very unstable for me. How can I downgrade to previous versions?

    0
    Comment actions Permalink
  • Jean-Noël Canches

    Since the upgrade, I am not able to connect via my android app (v5.6) to the hub configuration... and so I am not able to enable XMPP.

     

    The error shown on the app is E3600.

     

    I'm still able to change activity etc

     

    Thanks for helping me.

    0
    Comment actions Permalink
  • Jean-Noël Canches

    I found the solution: empty cache of the android app and restart it.

    0
    Comment actions Permalink
  • Jürgen Greil

    Android... 🤦???

    0
    Comment actions Permalink
  • Dave Leiner

    Got the update. XMPP seems OK so far with iOS.

    0
    Comment actions Permalink
  • Frank Thompson

    Just in case anyone uses the Unique ID stored on the hub like I did in my implementation. .250 changed it from a format of xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx (regex: [a-z=0-9]{8}-[a-z0-9]{4}-[a-z0-9]{4}-[a-z0-9]{12}) to xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx (regex: [a-z]{40})

     

    I use the Unique ID to keep track of the hubs in my application. It's not necessary, but I don't like to depend on IP or Name. So far UniqueID has been steady for me except when you factory reset the hub (which is expected). This if the first time I've noticed a change in the format and/or value from a firmware update.

    0
    Comment actions Permalink
  • Jürgen Greil

    Is it possible to transfer the Unique ID of one hub to another? (In case of exchanging one and so then don't need to change everything in Homekit/Homebridge).

    0
    Comment actions Permalink
  • Michael Bell

    Didn't work for me.

     

    I had working a system when I went to bed and got up to one not working. Followed the instructions to enable XMPP. Which didn't work.

     

    So tried a downgrade to 210 that was working and found that no longer works either.

     

    So upgraded to 250 again, disabled XMPP then re-enabled it again and still not working.

     

    Setup is Harmonyhub plugin in Homebridge in Docker on a Synology NAS and Apple HomePod.

     

     

    0
    Comment actions Permalink
  • Jürgen Greil

    Exactly the same problem as @Debmoor here!

    Very, very frustrating!

    Best thing to do is to return hubs as defect as they are currently!!!

    0
    Comment actions Permalink
  • Frank Thompson

    @mensa84 I would contact the developer of your implementation and ask them to add that feature. Should be a pretty easy addition.

    0
    Comment actions Permalink
  • g r

    it works when deleting data and cache of the app

    0
    Comment actions Permalink
  • Michael Bell

    Update

    I've just been into the Home app on my iPad and found duplicate switches for all my Harmony activities but in a different room and "they work" while my original switches don't work.

    So I think the next step will be delete Homebridge from Homekit to remove all switches the set it all up again.

    0
    Comment actions Permalink
  • Jürgen Greil

    @Michael Bell? which harmony plugin exactly do you use?

    0
    Comment actions Permalink
  • Michael Bell

    I'm using the Homebridge-harmonyhub plugin

    https://www.npmjs.com/package/homebridge-harmonyhub

    I've removed Homebridge from my Home app. Deleted the Harmony app from my iPad

    set everything up again and I'm still getting 2 switches for each activity, one that works and the other doesn't.

     

    Homebridge is identifying my 10 activities but when I add Homebridge into Homekit it says 2 accessories giving me 20 switches.

     

    Any suggestions gratefully received.

    0
    Comment actions Permalink
  • Michael Bell

    Well I've tried as much as I can.

    Deleted the Harmony app from my iPad.

    Deleted then recreated the Docker container for Homebridge and set up everything again.

     

    But I'm still getting 2 switches in Homekit for each activity. One that works and one that doesn't.

    Its as if the Homebridge-Harmonyhub plugin is seeing 2 instances of the Harmony hub, one that works with XMPP and one that doesn't.

    I know its working but having a load non working switches is annoying so I'm being to think the harmony is not worth the effort.

     

    Maybe dump it and get a Broadlink RM WiFi/IR/RF which has a Homebridge plugin

     

    0
    Comment actions Permalink
  • Michael Bell

    Fixed the duplicate switches problem.

    When I deleted the Docker container it left behind the Homebridge folder.

    Removed homebridge from the Homekit app. Stopped it deleted contents of persist and accessories folder. Restarted and added back into Homekit.

     

    All OK now, but I could do without having to redo things whenever a firmware update is pushed out.

    0
    Comment actions Permalink
  • Frank Thompson

    @Michael Bell? chances are your "settings" were left behind and as I mentioned above Logitech change the unique id format and length. I would guess the developer, like myself, uses the Unique ID to store settings for a given hub (as IP or name could change) You might want to let the developer of your integration plugin know to account for that. I had to do some behind the scenes in my implementation to map the old IDs to the new ones as the hubs were updated.

    0
    Comment actions Permalink
  • Hosteen Storm

    Thats all fine and dandy, BUT ...

    It would be prudent, now that the XMPP API became "official" at least to the extent that if it sets the world on fire, no one can blame big "L", to at least provide a change log when you DO change something. The update has broken at least half-dozen integrations, Athom Homey (detects the hub but no devices / activities returned), Hombebridge (as per above), etc.

    We do appreciate that you have listened, but it would be nice to be in the loop and not to wake up to the fact that the firmware has been updated automatically and all of the sudden stuff no longer works ...

     

    Cheers,

    TBP

    0
    Comment actions Permalink
  • Michael Bell

    Well got up again this morning to not working again.

    In fairness nothing todo with the update. It was caused by an interruption on my WAN causing the Harmony hub to lose connection so Homebridge lost its connection to the harmony.

     

    The obvious solution is to make the Harmony hub Homekit compatible but I'm not holding my breath on that happening.

    0
    Comment actions Permalink

Please sign in to leave a comment.