Sustainability Navigation

G Hub is not starting and hang in the loading screen

Answered

Comments

6 comments

  • Official comment
    Logi_Manny

    Hello André Strauß,
    Thank you for contacting Logitech regarding this concern about G Hub that keeps on loading.

    If G hub is just loading, please follow these steps:


    1. Press the Windows key, type “This PC”, and press Enter.
       You should see this window:
     

    1. Select your C:\ drive, navigate to the View tab, Click Options to bring up Folder Options, Navigate to the View tab, and Select Show hidden files, folders, and drive. Then Click Apply.

    Please try the following troubleshooting steps:
       1.     Download the latest installer for Logitech G HUB at: https://support.logi.com/hc/articles/360025298133
       2.     Uninstall G HUB.
       3.     Navigate to C:\Users\(username)\AppData\Roaming and delete the LGHUB folder.
       4.     Navigate to C:\ProgramData and delete the LGHUB folder.
       5.     Reboot your machine.
       6.     Reinstall G HUB.


    Note:

    If you are still experiencing issues with G HUB installation/update, try the following:
       1.     Launch Task Manager (ctrl+alt+del).
       2.     End LGHUB.exe.
       3.     End LGHUB Agent.exe.
       4.     End LGHUB Updater.exe.
       5.     Navigate to C:\Users\(username)\AppData\Roaming and delete the LGHUB folder.
       6.     Navigate to C:\ProgramData and delete the LGHUB folder.
       7.     Reboot your machine.
       8.     Re-install G HUB.

     

    Best regards,
    Logi_Manny

    Comment actions Permalink
  • Kåre-Martin Markovic

    The same is happening too! i ordered a Logitech G502 Wireless mouse. 

    1
    Comment actions Permalink
  • 0
    Comment actions Permalink
  • Matthew G

    I followed the steps supplied and it worked however after I put my PC to sleep it started again upon waking.. Any other options to fix this issue? It would be nice to have some variety with my keyboard light scheme.

    2
    Comment actions Permalink
  • Michael5434

    None of the tips presented here helped.

    But: G HUB only starts properly in the "Administrator" user account; not in my account (not even with administrator rights):

     

    G HUB only shows the G logo in an endless loop and does not start

    It affects not only the keyboard, but also my Logitech mouse G502 Lightspeed and my Logitech steering wheel G29 and my Logitech headset G 933. I can no longer configure anything because the Logitech G HUB software no longer wants to open. I always only have the animated G logo, but the software doesn't get any further.

    I uninstalled everything (and cleaned it, including the Registery) and reinstalled it several times. Sometimes with admin rights, then again without. Tried tips from the Internet (I'm not alone with this problem, others have it too), which did not help. Now I'm finished with my Latin. I even reinstalled Windows 10 Pro 64bit (latest version 2004) and tried different USB sockets; wireless as well as with cable. Still the same problem.

    The RGB lighting keeps flashing, that's annoying. If you could switch on at least one blue (Logitech) or white steady light. And at these expensive prices. I hope you can help me. Otherwise it was with Logitech (I have been and remain with Logitech for decades).

    P.S. I am a system administrator by profession, so I have extensive PC knowledge. nevertheless this was of no use to me here. The operating system is Windows 10 Pro version 2004 (G HUB no longer worked with version 1903).


    It seems to be due to the latest version of 2020.3.44132.0 from G HUB.

    I once copied all the data from the previous G HUB-version from an Windows-Image into my current Windows installation (unfortunately I did not have a direct setup of this previous version, since the update was carried out directly by G HUB).

    Then the software opens and all devices are displayed, but wants to carry out an update immediately (should restart the software - light blue border at the bottom of the software window with a corresponding message). As long as I don't click on restart, I can set everything in G HUB (I have transferred the standard mouse and keyboard profiles I created to the device's internal memory - so no more annoying flashing).

    But ultimately a restart cannot be avoided (at the latest when the PC is started up again, for example, the next morning), the update is carried out (although I had removed the checkmark in the software - but this would probably only happen the next time G HUB apply). After the update, only the endless animation of the G logo again.


    The update 2020.4.47660 for G HUB software released 2020-06-10 did not solve the problem either.

    So I opened a ticket at Logitech before five days but didn't get any answer.


    Michael

    0
    Comment actions Permalink
  • Michael5434

    I solved the problem by deleting and creating my user account.

    Like the above YouTube video describes, G HUB apparently has problems with the fact that when logging in with a Microsoft account (email address) the actual user name under "C:\Users" is shortened to 5 digits. This mismatch between the user name when logging on to Windows and the user name under "Users" causes the program to get stuck when starting G HUB.

    I have therefore used a shorter user name for the Windows login, which is no longer garbled under Users ". Now it works.

    And Logitech hasn't answered in a week. So never again Logitech.

    1
    Comment actions Permalink

Please sign in to leave a comment.