Sustainability Navigation

g903 double click issue

Answered

Comments

1 comment

  • Official comment
    Logi_Manny

    Hello Benjamin6017
    Thank you for contacting Logitech regarding this concern about your G903 Wireless Gaming Mouse.

     

    Please try these steps and please let us know if these steps helped fix the issue:

    • If you have multiple devices plugged into the computer, isolate the issue by temporarily removing other USB devices on the computer and test the device. 
    • Prefer using USB 2.0 rather than USB 3.0 ports.
    • Adjust double-click sensitivity in the Mouse Properties > Buttons tab > Double-click speed (In Mac OS X: System Preferences > Mouse > Double-Click Speed) 
    • Tick the "Double-click to open an item" in the Folder Options section of Windows
    Swap the primary and secondary click function for testing (For Windows: Mouse Properties > Buttons tab > Button Configuration | For Mac: System Preferences > Mouse > Primary Mouse Button) 
    • For further testing, uninstall Logitech Setpoint and other third-party applications which is capable of configuring mouse actions (MS Intellipoint, SteerMouse, USB Overdrive, etc.) 
    • Clean the left-click button with a compressed can of air (optional) 
    • Test the button on several programs, browser and application and check if issue is consistent. 
    • Test the mouse on another port or another PC (if available).

     

    Best Regards,

    Logi_Manny

    Comment actions Permalink

Please sign in to leave a comment.