Sustainability Navigation

Having trouble detecting or syncing your Harmony remote on mac 10.15.4

Comments

68 comments

  • Vaughan Wingfield

    PKHarmony "Can you please let me know the problem you're facing to help us understand and troubleshoot further."

    Certainly. See posts 1, 13 (which has a photo showing the remote screen saying "USB Connected" and screenshots of the software and the Mac "about" screens), 16 (describing other failures during syncs), 19 (describing how the cable works on an older Mac using older software, leading me to doubt that the cable is the issue), and 26 (where I replied that I had already removed and replaced the batteries to reboot the remote multiple times, to no avail).

    I've used several cables (that work on an old system using the previous software) and the cables are connected directly to the computer, not via a hub.

    I also see lots of comments from other posters saying that they are still having problems. I see replies saying that the Windows version works, the problem is with the Mac software. I repeat, if I go get an outdated Mac from storage, switch my monitor, mouse, and keyboard, and use the pre-Catalina version of the software...it will work. That's more trouble than I want to deal with regularly. The problem is with the Harmony Desktop software for Catalina.

    The error messages are not limited to E1400. I see a reference to E1600, I have gotten it myself. My favorite error message that I have gotten is "ERROR ! This is unfortunate. Please restart your app to proceed", but I already put that in a post a month ago. The most common issue I see is the software not seeing the remote even though the remote has a screen saying that it is connected. That or not responding at all. But the desktop experiences lots of errors, not just a single one.

    Most of the recommendations from support are variations on the old theme, "It's leaving here OK, the problem's on your end." I just grew tired of fooling with it. Looks like lots of others are discouraged too. There are way too many posts from others with problems (still), to say that version 1.0.271 fixed the problems. It should be obvious that is not the case.

    1
    Comment actions Permalink
  • Jay Sitter

    If you tap the “Follow” button near the top of this thread, you should receive notifications when there is a new post.

    0
    Comment actions Permalink
  • howardlamby

    Seems to have worked, thank you.......... Why theses things happen, I don't know

     

    0
    Comment actions Permalink
  • Bob Berres

    Works great for me! Thanks Logitech!

    0
    Comment actions Permalink
  • Multimediaknaller B

    Werkt prima en ook een heel stuk vlotter 😃

    0
    Comment actions Permalink
  • Jennifer Garcia

    Part of Roberts problem may be the insane way that logitech forces us to use their proprietary cables in order for us to sync.

    You must use their cable (and not just any of their cables - one for charging your mouse wont work, neither will one for a Touch remote work with a 650).

    This proprietary BS is very annoying.

    So using the proper cables I was able to sync today with the software update - thanks.

     
    0
    Comment actions Permalink
  • Robert Whetstone

    I have no idea where the original cable is. Help

    0
    Comment actions Permalink
  • PKHarmony

    Vaughan Wingfield & Robert Whetstone,

     

    Though we recommend to use the original cable. But it should work with any usb cable that passes data. I use my old android phone's cable to Sync my Harmony remote. 

     

    If you've tried using different cables & usb ports, then try to reboot the remote by removing the batteries and inserting it again and then try again. 

    0
    Comment actions Permalink
  • Multimediaknaller B

    Remove the old software with the program below ☺️

     

    https://freemacsoft.net/appcleaner/

    0
    Comment actions Permalink
  • Thierry6854

    Hi all,

    Works fine for me. Thank you Logitech!

    Thierry

    0
    Comment actions Permalink
  • PKHarmony

    Hi Vaughan & William,

    Can you please check the suggestion posted in this Reddit thread, where customers experience problem with USB after updating to Catalina 10.15.4.

     

    https://www.reddit.com/r/MacOS/comments/fpwf1s/usbc_port_not_working_after_update/

     

     

    0
    Comment actions Permalink
  • howardlamby

    I feel everyone's angst... It worked for me, but that was then, I haven't tried since, 

    If ONLY I had non mac computer I'd have no problems.

    I hate Macs... My wife loves them. 

    I know it's not the fault of macs.. But why does it work on a PC and a problem on macs? 

    0
    Comment actions Permalink
  • Bob Gare

    This software sucks for Mac.  Doesn't work or look like the videos show.   i have 9 components and to save a new HDMI setting for example I find it easier to delete everything and reinstall it than try to change it after.  How about OLD Fashion drop down menus and short cuts to simply make a change.   I've never been able to find the screen to change button functions.  Is it even in the Mac version?  

    0
    Comment actions Permalink
  • Bob Gare

    If you can't write software that does everything easily on a MAC.  Go back to the way you did it years ago where we did all our updating and programing from your web page.  Pretty simple right?  One program for all computers because it's done online.  

    0
    Comment actions Permalink
  • K G

    Wow. This forum has a 2+ day approval policy for posts?
    Bad software
    Bad support
    Can you do it any worse!?

    0
    Comment actions Permalink
  • WilliamWiseman8510

    Soooo... I just bought a 665 to replace my 660 which I could not sync. The 665 loaded and synched just fine. Tried the 660 again and no sync. Tells me the issue is with the firmware in the 660 remote so it’s basically useless now because logi can’t figure this out... ugh had to spend $65 of my own money to fix their issues. Asshats....

    0
    Comment actions Permalink
  • Matt Huesmann

    I went through 5 USB cables and found one that went with a newer device worked. So it was NOT a Logitech cable but it is NOT true that any USB cable will work. The ones I own all work on hard drives, but I found a cable that is normally used to POWER charge a device. (Led light) That cable worked with my remote 650 model.

    Maybe that will help some of you.Try a USB cable that is normally used to power charge a LED lights or something similar. NOT just a USB hard drive connection cable.

    0
    Comment actions Permalink
  • PKHarmony

    @Christopher Poggiali, As we informed earlier, we've fixed that issue in the 1.0.271 version of the Harmony Desktop App. If you're still getting the error then it could be different one. If you have added unsupported BT/IP devices (Like PS3/PS4, Hue, Roku Stick, Alexa, Google Home, etc.) or if any of your device names contains emojis/smileys then you might get this E1400 error.

    I'd recommend you to remove the devices or remove the emojis/smileys from the device and try to Sync again.  

    0
    Comment actions Permalink
  • Christopher Poggiali

    PK, as per your reply...

    (As we informed earlier, we've fixed that issue in the 1.0.271 version of the Harmony Desktop App. If you're still getting the error then it could be different one. If you have added unsupported BT/IP devices (Like PS3/PS4, Hue, Roku Stick, Alexa, Google Home, etc.) or if any of your device names contains emojis/smileys then you might get this E1400 error.

    I'd recommend you to remove the devices or remove the emojis/smileys from the device and try to Sync again.)

     

    Not sure what you mean by "removing the devices"? I have a PS4, Hue, Google Home, etc.....Remove them from where? Disconnect? Please be a little more specific. I appreciate the help. TY

     

    0
    Comment actions Permalink
  • PKHarmony

    @chris, sorry for not being clear enough. If you have added PS4, Hue, Google Home, etc. in your Harmony account, then you need to remove those device from the Harmony account and try to Sync the remote. 

    Because, Harmony Desktop App is for IR remotes and Harmony IR remotes (like Harmony 200/300, Harmony 350, Harmony 650/665/700, Harmony Touch/Ultimate One, Harmony 950) do not support the BT/IP devices like PS4, Hue, Google Home, Fire TV, etc.   

    0
    Comment actions Permalink
  • RoyFFP

    Since 2011 I've had three remotes – H900, Elite, and H650, none of which have been able to sync with my iMac nor MacBook Pro. There is only one way to fix this!!! Buy yourself a second hand Windows laptop. Syncing is beautiful. As it should be.

    Their Mac software is the worst piece of **** I have ever had the misfortune to install! After many months of complaining, and wasted hours & hours of frustration, it's been worth the extra money.

    When I signed in to this forum a couple of days ago to see if anything had changed I thought I'd skipped nine years into the past – same old unresolved problems!

    Roy P

    0
    Comment actions Permalink
  • RoyFFP

    However, having written the above last night, I rebooted into my Catalina partition, downloaded the MyHarmony software and tried to sync the H650. After 3 failed attempts it synced!!! Cannot believe it! Also, much, much better layouts. So much better than the old software.

    Of course this doesn't help the people who are still having problems.

    Sorry!

    Roy P(S. I should mention that the three failed attempts were preceded by the old chestnut "We are having problems finding your remote" (words something like that).

    0
    Comment actions Permalink
  • Vaughan Wingfield

    Glad you were able to get it to work, Roy. Congratulations!

    I'm going to hold onto the position that three failures before getting lucky and having success is still not the behavior of properly working software. 

    I agree that the layout is nice. There's nothing wrong with how it looks

    On edit: After thinking about it further, I think it says something about Desktop's reliability when I felt compelled to congratulate you for completing a successful run. (I'm also a little jealous. ;-) )

    Have a good weekend, everybody.

    0
    Comment actions Permalink
  • Christopher Poggiali

    OK, this is what I did.......I deleted the remote. I proceeded to add each component one by one, syncing each as I went. Synced my T.V., no problem. Synced my receiver, no problem. Synced my cable box, no problem. WHEW!.......Went to start syncing other components like my X-Box, My Google Home, My Chromecast, etc....Looked like things were going smoothly but when I went to utilize them, problems arose. However, I figured out that I really just need to have the 3 first components synced since I can use the remote to change the inputs on my receiver. So I started over and just added those 3 and forgot the rest. That works. No problem. I actually have to get up to grab the controllers for my game systems anyway so turning them on without the remote is not a big deal. The one caveat is that before I had trouble with this, the Top Left off button used to turn on and turn off my 3 components to watch T.V.. Now, it's only for turning off and I have to press the T.V. button below it to turn them on. I don't understand this. I must have had the remote setup in a certain way earlier that allowed it turn and turn off. There are no clear instructions from what I can gather.

    0
    Comment actions Permalink
  • Vaughan Wingfield

    Wow! All I am trying to sync is my TV (Hisense Model 43H6D) and OTA DVR (Channel Master Stream+).

    I've had to switch to my outdated Mac (pre Catalina) using the old software to get it to work at all. I've never successfully completed a sync using the version 1.0.271 Harmony Desktop. I've rarely been able to get it to even start.

    I've got a TiVo Edge for Antenna version coming next week to replace the Stream+, so I'll be starting all over again then.

    0
    Comment actions Permalink
  • RoyFFP

    Good luck with that, Vaughan!

    Roy P

    0
    Comment actions Permalink
  • Eduardo Roizman

    I was facing the same problem to sync my Harmony 650 using Mac and Windows PC.

    I have a Harmony 950 also, which was syncing perfectly.

    Yesterday, I decided to delete the 650 of my account and configure it again as a new remote.

    It worked!

    I spent half an hour but now it is syncing perfectly.

    Hope it helps.

    0
    Comment actions Permalink
  • howardlamby

    excellent Eduardo, it feels good when a problem is solved doesn't'it?

    0
    Comment actions Permalink
  • Kevin8024

    I faced the E1400 error... I had to totally remove my remote and set up it again... 

    0
    Comment actions Permalink
  • MIKE STAN

    With the release of macOS 10.15 Catalina, 32-bit apps such as MyHarmony will no longer launch and instead display an error message. For more information, see Apple's announcement regarding their transition to 64-bit technology.

    bluestacks omegle

    0
    Comment actions Permalink

Please sign in to leave a comment.