Sustainability Navigation

Mx 3 master and airpods pro microphone issue

Answered

Comments

116 comments

  • Luis Suárez

    I'm having the exact same issue here. 

    As everyone said before, I can confirm the robotic voice goes away immediately when turning off my Logitech MX Master 3 for Mac.

    It is clear to me that the problem is in the mouse BT connection. It works perfectly fine when the mouse is off. (Also happen to have a BT KB -generic- and it doesn't affect my Airpods 3 BT connection)

    You can do better Logitech.

    0
    Comment actions Permalink
  • Bruno M

    I'm having the same issue with my MX Master 3s, the audio will not work while the mouse is on. I just bought two MX and luckily I can still return them. Very disappointing.

    0
    Comment actions Permalink
  • Brandon Wexler

    Kevin Lisa Volodymyr Sobotovych sam ranjith Matt Gardenghi Alvaro Agea Herradón Pankaj Singh Jason Braatz Please upvote/comment on this new thread given Logitech marked this one answered and has not replied to my request to open it: https://support.logi.com/hc/en-us/community/posts/7992495542935-AirPods-Pro-Robotic-Voice-with-Logitech-MX-Peripherals

    2
    Comment actions Permalink
  • Aleksei Leontev

    I dont understand how this was marked answered

    1
    Comment actions Permalink
  • Kevin

    If you all feel so inclined, you could leave a review on the product you purchased as well. Doesn’t seem like the support forums are getting much traction but reviews might.

    0
    Comment actions Permalink
  • sam ranjith

    We might need to take this to cnet or MacRumors. How can such a publicly traded company be so deaf to its customers' complaints? Too arrogant that they don't want to reply or give a status regarding this issue.

    1
    Comment actions Permalink
  • userSundevil

    While I'm glad I finally isolated the issue & figured out why everyone was complaining about me sounding like a robot during meetings, I do like my new Master MX 3, and would prefer not to return it. However I also don't want to have to plug in my $10 wired mouse every time I have a meeting...I would have predicted Apple would direct me to Logitech support & vice-versa... pretty typical for stuff like this. Now that I'm done complaining - 

    Anyone know if connecting via the Logi Bolt USB Receiver instead of Bluetooth will resolve this issue?

    1
    Comment actions Permalink
  • Kostiantyn M.

    Yes, with Bolt receiver it will work fine.

    But this is ridiculous 

    0
    Comment actions Permalink
  • Kevin

    userSundevil I was still having issues even when connected to the Logi Bolt receiver, but it seems like the issue isn't as consistent for everyone as it is when connected via Bluetooth.

    1
    Comment actions Permalink
  • Kevin Nelson

    I am having the same issue now that I moved to a 2019 MBP. My previous 2017 model MBP worked fine with my Air Pods Pro and Logitech MX3 mouse. Now I am getting the robotic voice. When I remove the mouse, the audio is normal. If I re-connect the mouse, the roboto voice is back. This is really stupid!!!

    1
    Comment actions Permalink
  • Kostiantyn M.

    Anybody tested with new AirPods? 

    0
    Comment actions Permalink
  • userSundevil

    I have resorted to keeping a wired mouse plugged in & turning off my MX mouse whenever I have a meeting. Pretty silly thing to have to do with a $100 mouse, but I don't see a better option. I've already been nicknamed "mr roboto" by coworkers because of the ridiculous robot-voice that it causes.

    1
    Comment actions Permalink
  • sam ranjith

    sam here. But tired of posting and asking Logitech to fix the issue. I don't think, they have a clue about what is happening with their own product or they hit some technical limitation of Bluetooth bandwidth and they don't have a fix. 

    1
    Comment actions Permalink
  • Max

    Same for me. Bought new Logitech K850 + mouse M720 and now I can't do meetings with EarPods pro. That is so disappointing. Will give away keyboard and use something else.

    0
    Comment actions Permalink
  • Taha Sevim

    The problem continues with airpods pro 2nd generation. Hundreds of the same problems have been reported for this problem. and it has not been solved for months when will it be solved?

    2
    Comment actions Permalink
  • Cavit Pınar

    Shame on you Logitech. It's been a year and your team hasn't come up with a solution yet. Your products are absolute regret for Mac users.

    1
    Comment actions Permalink
  • Kostiantyn M.

    Not reproducing anymore on MacOS Ventura 13.0 (22A380)! 

    Can anybody else confirm the same? 

    1
    Comment actions Permalink
  • Brandon Wexler

    That’s great news Kostiantyn M. I have since moved onto a Apple silicon MacBook, but am very glad the issue may be resolved (at least for you).

    0
    Comment actions Permalink
  • Cameron Sumpter

    I am also seeing this issue on a 2021 16" MBP w/ Airpods pro 2 and mx master 3s

    0
    Comment actions Permalink
  • userSundevil

    I can confirm this is still a problem with my brand new Macbook Pro 13". I have a $10 wired mouse connected to my USB hub for just this reason, so when I have a meeting I want to use my Airpods for, I switch to that. It's almost funny that there are cases where my $15 wired headset & $10 wired mouse work better than my $100 mouse & $200 headphones.

    0
    Comment actions Permalink
  • Kostiantyn M.

    What OS version is it running? 

    0
    Comment actions Permalink
  • userSundevil

    I've been on Monterey the whole time; current version I'm working with is 12.6 (21G115)

    0
    Comment actions Permalink
  • Kostiantyn M.

    Try Ventura. It was released few days ago.

    It fixed problem for me completely. 

    0
    Comment actions Permalink
  • userSundevil

    I've learned that lesson the hard way ... no way will I update the OS until it's been available at least a year if I can help it. It's not worth running into a slew of other issues that'll come up with random 3rd parties not keeping pace with Apple's updates...been burned too many times, like the expensive HP color printer I just hucked into the dumpster because they just refused to continue supporting mac OS updates. It's very annoying, but it doesn't stop me from getting work done.

    0
    Comment actions Permalink
  • Shawn Thompson

    Kostiantyn M. I updated yesterday to Ventura on my M1 MacMini and switched my MX keyboard and mouse from USB to direct bluetooth.

    So far no echo with my AirPods Max after a 30 minutes Teams call. 

    Let's hope the problem has been fixed. 

    Never mind, it's back

    -1
    Comment actions Permalink

Please sign in to leave a comment.