Sustainability Navigation

Logitech g-hub doesnt recognize the g29 steering wheel on macbook m1

Answered

Comments

3 comments

  • Official comment
    Shrivathsa

    Hey Pompilio, 

    Thanks for reaching out and we are sorry for the delay in response. 

    We kindly request you to follow the below steps and check if that helps to resolve the issue: 

    1. Try with a different power source.
    2. Plug the device into a different USB port on your computer. If possible, don't use a USB hub or other similar device. If using a different USB port works, try updating the motherboard USB chipset driver: https://support.logi.com/hc/articles/360023370233
    3. Check the cables: https://support.logi.com/hc/articles/360023180914
    4. Try update the device's firmware:
    • Download and install Logitech G-Hub (Available here: https://www.logitechg.com/innovation/g-hub.html)
    • Launch the software, select the device from the home screen then go to Settings
    • If a firmware update is available, a Blue "Update" button would appear under the firmware version on the top right corner of the screen
    5. Press Windows + R key to open the run command box.
    6. Type joy.cpl to open the Windows Game Controller Settings.
    7. Select the entry for the gaming wheel.
    8. Press CTRL + SHIFT while clicking Properties.
    9. Go to Settings tab and click Calibrate.
    10. Follow the calibration instructions then test the wheel afterwards.
    11. Try testing the device on a different computer.

    Regards,
    Shrivathsa
    Logi G Support.

    Comment actions Permalink
  • Pompilio Gomes

    Hi Shrivathsa, thank you for answer.

    I am trying to use the g29 on my macbook air m1 (monterey version 12.5.1 (21G83)).

    I have connected other devices and the USB ports are working properly.

    The device is working correctly, I have already tested it on another computer.

    The problem is that the Logitech G HUB software doesnt recognize the G29 device.
     
    I already tried to uninstall and install the software again, restart the notebook. But none of that worked.
     
    I have attached some images maybe it will help you to identify the problem.
     
    Let me know if I can help with any more information.
     
    Thank you very much.
     

     

    0
    Comment actions Permalink
  • Shrivathsa

    Hey Pompilio, 

    Thanks for following up and letting us know the outcome. 

    We kindly request you to follow the below steps and check if that helps to resolve the issue: 

    (NOTE: Please start by creating a backup of your G HUB settings if you wish to retain them.

    - Click on Go from the menu bar and then select Go to Folder.
    - Type in ~/Library/Application Support/lghub and click Go.
    - Find settings.db and create a copy of it on your desktop or a different location of your choosing.)

    1. Uninstall G HUB if showing as installed
    2. Click Go
    3. Press and hold the Option Key (Library folder will appear)
    4. Click Library
    5. Open Application Support Folder
    6. Delete lghub folder
    7. Go to search (magnifying glass icon, upper right corner)
    8. Search "ghub"
    9. Delete all results
    10. Restart
    11. Re-installing G HUB: https://www.logitechg.com/innovation/g-hub.html
    12. Allow G HUB in privacy settings

    If the issue persist, create new MAC profile and follow steps 1-12 again

    Regards,
    Shrivathsa
    Logi G Support.

    0
    Comment actions Permalink

Please sign in to leave a comment.