Sustainability Navigation

Comments

5 comments

  • Official comment
    Shrivathsa

    Hey Peteroku, 

    Thanks for reaching out and we are sorry to hear about the inconvenience caused. 

    We request you to follow the below steps and check if that helps: 

    • Uninstall G-HUB. Download the latest G-Hub installer https://support.logitech.com/software/lghub

    • IMPORTANT: Before running the installer, go to System Preferences › Security & Privacy and unlock the preferences by clicking the Lock icon in the bottom left and entering your admin credentials.

    • Now run the G-Hub installer.
    • Follow all the prompts.
    • Complete the installation.
    • Once done, launch System Preferences.
    • Click on Security & Privacy.
    • Click the Privacy tab.
    • In the left panel, click on Accessibility and check the boxes under Logitech G-Hub to provide access. If you are unable to interact with the checkboxes, please click the lock icon on the bottom left corner and then check the boxes.
    • If a feature requires access to any specific item such as System Events or Finder, you will see a prompt the first time you use this feature.
    • Please note that this prompt appears only once, requesting access for a specific item. If you deny access, all the other features that need access to the same item will not work and another prompt will not be shown.
    • Click OK to allow access for Logitech G-Hub so that you can continue to use these features.
    • In case you click Don’t Allow, use the following steps to allow access manually:
    • Launch System Preferences.
    • Click Security & Privacy.
    • Click the Privacy tab.
    • In the left panel, click Automation and then check the boxes under Logitech G-Hub to provide access. If you are unable to interact with the checkboxes, please click the lock icon on the bottom left corner and then check the boxes.

    • NOTE: If a feature still doesn’t work after you grant access, please reboot the system.

    Regards,
    Shrivathsa
    Logi G Support.

    Comment actions Permalink
  • cong minh tran hoang

    Hi Shrivathsa,

    I still have issue "initializing profile". Although I followed your comment. 

     

    0
    Comment actions Permalink
  • cong minh tran hoang

    I didn't see ---> " click Automation and then check the boxes under Logitech G-Hub to provide access"

    0
    Comment actions Permalink
  • Shrivathsa

    Hey there, 

    Thanks for following up. 

    It's possible the most recent update also reverted the "Super Stereo" surround mode settings to default which would have affected things like browser audio and Discord sounding correct. If this is the case for you, check the "Super Stereo" mode settings in the device Surround configuration in G HUB to find the correct setting.

    Regards,
    Shrivathsa
    Logi G Support.

    0
    Comment actions Permalink
  • steave mr

    It's possible the most recent update also reverted the "Super Stereo" surround mode settings to default which would have affected things like browser audio and Discord sounding correct. If this is the case for you, check the "Super Stereo" mode settings in the device Surround configuration in G HUB to find the correct setting.

    0
    Comment actions Permalink

Please sign in to leave a comment.