Sustainability Navigation

Comments

8 comments

  • Official comment
    D KARTHIK

    Hi Sam,

    Thanks for reaching out and sorry to hear about the experience with MX Master 3.  We'd love to help you open a case to provide a solution directly over email. 

    Thanks so much, and looking forward to getting you in touch with the team.

    Regards
    Karthik
    Logi Support

    Comment actions Permalink
  • wicharek

    Having the same issue.
    MacBook Pro 2019 + MX Anywhere 3 for Mac + Air Pods Max = robo voice on mic

    The problem is widespread and 100% reproducible. Logitech should work with Apple and provide a fix.

    1
    Comment actions Permalink
  • D KARTHIK

    Hi there,

    Thanks for reaching out and sorry to hear about the experience with MX Master Anywhere 3. We'd love to help you open a case to provide a solution directly over email. 

    Thanks so much, and looking forward to getting you in touch with the team.

    Regards
    Karthik
    Logi Support

    0
    Comment actions Permalink
  • Kevin Nelson

    I am having the same issue now that I moved to a 2019 MBP. My previous 2017 model MBP worked fine with my Air Pods Pro and Logitech MX3 mouse. Now I am getting the robotic voice. When I remove the mouse, the audio is normal. If I re-connect the mouse, the roboto voice is back. This is really stupid!!!

    0
    Comment actions Permalink
  • D KARTHIK

    Hey Kevin,

    Thanks for reaching out to us.

    Thank you for bringing this issue to our attention. We would like to inform you that we are currently working on this. We would like to inform you that we have already passed this query to our team, they will look into it. Please check out our website for further updates.
     
    Regards
    Karthik 
    Logi Support

    -1
    Comment actions Permalink
  • Kumar Kayastha

    Update: MacBook Pro 2019 + MX Master 3S (new model!) + Air Pods =  STILL Having Robo Voice on Mic

    This thread (posted above) has over 100 comments with the SAME COMPLAINT. Why is this marked as answered or resolved anywhere??? I love my new mouse (as well as the multiple other Logi peripherals I own: keyboards, mice, cams...) but maybe it is time to check out other vendors since actually coming up with a true resolution seems to be the lowest of priorities.

    Clearly, the Logi Support team "looking into it" & "currently working on this" is a joke. I upgraded to an entirely new mouse just in hopes of this being resolved.

    What. The. Hell.?!?! Thanks for the "support"!

    1
    Comment actions Permalink
  • Taha Sevim

    The problem continues with airpods pro 2nd generation. Hundreds of the same problems have been reported for this problem. and it has not been solved for months when will it be solved?

    1
    Comment actions Permalink
  • Brandon Wexler

    FYI: I’ve emailed two popular Mac/Apple news and rumors sites about this issue, including links to this thread and multiple others, in hopes Logitech can actually address the issue or at the very least stop pretending to have addressed it.

    0
    Comment actions Permalink

Please sign in to leave a comment.