Sustainability Navigation

Comments

1 comment

  • jrosa
    Hello @Nebojsa Icic ! Welcome to the Logitech Community! :) Our team will be happy to help you! Circle is compatible only with Android and ios devices, running iOS 8.1 or newer with iPhone 4s or newer, iPad mini or newer, iPad 3 or newer, iPod touch (5th generation) or newer Android 4.4 or newer with Bluetooth Smart Ready device For web browser (desktop and laptop) viewing: Operating system: Mac OS X v10.9 or later and Windows 7 or later. Browser: latest version of Safari, Chrome, Firefox or Internet Explorer If you have further questions, please let me know Thank you! Warm regards, LogiJae If this reply adequately addresses your issue, please mark it as Select as Best and click Like, so this information can benefit other community members.
    0
    Comment actions Permalink

Please sign in to leave a comment.