Sustainability Navigation

Google Assistant Integration

Comments

39 comments

  • AlessioR
    Same here with two separate Circle 1s. No matter what I do, all I get is unavailable stream.
    0
    Comment actions Permalink
  • charlie6990
    No can't get mine to work. When asked "what's on garden view" Comes up with, "I'm afraid there was an error and I'm unable to control your home device".
    0
    Comment actions Permalink
  • Logi_Aron

    Have you given your Chromecast device a reasonable name? If so, use the following language:

     

    Show <camera name> camera on the <chromecast name>

    Show 'Living Room' camera on the 'Bedroom TV'

     

    Make sure you don't have the word 'camera' in the name of your Circle camera or use emoticons or odd device names. We don't control the phrasing as that is purely handled by Google.

    0
    Comment actions Permalink
  • AlessioR

    Doesn't work. The Chromecast is called "Pivocast" and the cameras are called "Entrance" and "Alex", so no problems with the naming there.

    0
    Comment actions Permalink
  • Logi_Aron

    I'm not sure "pivocast" is a clean name that Google will pick up. We had real trouble until we picked safe names for all the devices. Another phrasing that might work:

     

    Stream the <camera name> on the <chromecast name>.

     

    Google can also get confused if you have room names with the same name as your camera names.

    0
    Comment actions Permalink
  • AlessioR

    I'll try shuffling names around, then. Camera names actually correspond to room names, in my case. Thanks.

    0
    Comment actions Permalink
  • Jonarogers

    Me: Show "Front Door" on the "Living Room Chromecast".

    Google Home: "It looks like the stream is currently unavailable from the Front Door."

     

    There is something off in the connection. Again, works on HomeKit, works in Alexa.

    "Alexa, show the Front Door"

    "OK" and it just shows up on my Fire TV.

     

    And before you suggest it - yes I've logged into Logi Circle in the Google Assistant. It shows my two cameras in the app. Is there some kind of limitation I'm not aware of?

    0
    Comment actions Permalink
  • AlessioR
    I changed all the names of devices, reset the cameras and relinked the Logi account but there are no differences whatsoever. Room Entrance: “Show hallway on projector” Room Alessio: “Show bedroom on projector” And I still get the same stream unavailable error.
    0
    Comment actions Permalink
  • Jonarogers

    Yup, it is not a naming issue. Can @Aron Rosenberg? confirm you are actually getting it to work with Google Assistant currently?

    0
    Comment actions Permalink
  • AlessioR
    Could it be something with firewall ports?
    0
    Comment actions Permalink
  • Jonarogers

    Thanks @Aron Rosenberg? - Well then I'm stumped. glad I'm not alone as a few others on this post seem to be having the same issue... I've tried disconnecting and re-connecting a few times to no avail. Any other thoughts?

    0
    Comment actions Permalink
  • Logi_Aron

    Update: We pushed a fix on our end and its working again.

     

    Looks like Google changed their API a few days ago and broke the integration with live stream. We will get it updated and fixed on our end ASAP.

     

    Thank you for being persistent, sometimes it takes that extra push for us to actually go check the integration as apparently even a 5 day old QA test sometimes isn't good enough.

    0
    Comment actions Permalink
  • AlessioR
    Thanks @Aron Rosenberg, guess we’ll just have to wait a little bit then.
    0
    Comment actions Permalink
  • Jonarogers

    No worries @Aron Rosenberg? ! Logitech's responsiveness is still multitudes better than your competition who I recently switched away from. Thanks for following up - these voice assistants are in a constant state of flux.

     

    While I have your attention, if you ever need public beta testers, happy to volunteer. Have all three home integrations and happy to thoroughly test features.

    0
    Comment actions Permalink
  • Logi_Aron

    We pushed a fix to our servers and it is working again.

    0
    Comment actions Permalink
  • Logi_Aron

    @Jonathan Rogers?

     

    The best thing you can do in the short term is go write a review on Amazon. We are working on a beta test program, but its not ready yet.

    0
    Comment actions Permalink
  • SulleyBoo7271

    I am experiencing the same issue... This is a new camera and I just installed this. I would assume that this push would have allowed this to occur. But yet, I experience the same thing...

    -show the front door

    -stream the front door

    -show the logitech camera

    -stream the logitech camera

    -play the front door

    Nothing works. Why?

    0
    Comment actions Permalink
  • Jonarogers
    Yeah @Aron Rosenberg looks like this issue is back. Any hope for a fix?
    0
    Comment actions Permalink
  • Logi_Aron

    I just had the team try it and it works for us here. We used "show me <camera name> on <chromecast device name>"

    0
    Comment actions Permalink
  • Jonarogers
    Every time I do that I get YouTube suggestions. “Show me front door camera on living room chromecast” just brings up a YouTube search with several options to pick from based on the title “front door camera”
    0
    Comment actions Permalink
  • Jonarogers
    Ha, so this is interesting. If I TYPE show me living room on living room chrome cast it works. If I speak, it does a YouTube search. Wonder if it’s a thing on google’s side? @Aron Rosenberg 
    0
    Comment actions Permalink
  • SulleyBoo7271

    Interesting... seems like a conversion issue in the phrase attempted to pass. But it seems like @Aron Rosenberg? is not experiencing the same issue. I get the same results as @Jonathan Rogers? ... YouTube suggestions.

     

    0
    Comment actions Permalink
  • Logi_Aron

    We have no control over how Google determines if its a YouTube or Logitech camera request. If Google deigns to send the request to our servers we will answer it, but if you are getting a YouTube response then the request was never sent to us in the first place. If you get an error back about not "not available" or "error starting stream" that means our servers aren't responding correctly.

     

    Other "odd" things can be if the camera name is too similar to popular YouTube content.

    0
    Comment actions Permalink
  • SulleyBoo7271
    That is very helpful. Depending on the phrase used, some of the phrases do state things such as unavailable or simply do not show any content. Let me determine those phrases and get back to you.
    0
    Comment actions Permalink
  • SulleyBoo7271
    Here are the responses I have received... Show [camera name]" I do not know where to play the video "What’s on [camera name]?" I do not know where to play the video "[Camera name] on [Chromecast device name]" sorry i do not know how to help with that yet "Play [camera name] on [Chromecast device name]" sorry i do not understand "Show [camera name] on [Chromecast device name]" Showing on Visio TV - YouTube videos Appreciate your assistance.
    0
    Comment actions Permalink
  • Logi_Aron

    @Jonathan Rogers? - What is the exact name you gave the camera in the Circle App? Is it "Living Room" or "Living Room Camera"? What is the exact name of your ChromeCast device?

     

    @Chris Evans? - If you type the request into the Assistant chat interface does it work for you? What are the exact names you gave the camera in the Circle App and the name of your ChromeCast?

     

    I want to escalate these issues to Google, but need a little more info before I can do that. I will also ask them if there is language that can't trigger YouTube.

    0
    Comment actions Permalink
  • Jonarogers

    Thanks @Aron Rosenberg?  In the Circle App I have two Cameras. They are named "Front Door" and "Living Room".

     

    In the Google Assistant App (iOS for whatever its worth) They are named "Front Door" and "Living Room". Neither have nicknames, and the info states "Name from Logi Circle".

     

    I have two Chromecast devices "Bedroom Chromecast" and "Living Room Chromecast".

     

    Again, if I type into Google Asst, it works. If I speak it to my google home devices, I get the YouTube searches.

    0
    Comment actions Permalink
  • Logi_Aron

    @Jonathan Rogers? What is the exact phrasing you are using when speaking. Your earlier posts had "Show me front door camera on living room chromecast". (Note the extra word camera). If you instead say "Show me front door on living room chromecast” (without the word camera), does it still fail? Does "Show me the front door camera on living room chromecast" work (note the addition of 'the')?

    0
    Comment actions Permalink
  • Jonarogers

    @Aron Rosenberg? I am at work, so I will have to try these when I get home. Sorry for the delay. I'm fairly certain I've tried variations of "show" "stream" "show me" "show me the" and none have worked verbally, but I'll try the full list tonight to be certain.

    0
    Comment actions Permalink
  • SulleyBoo7271

    Given the circumstances with this, I have returned the camera for now. 😞

    0
    Comment actions Permalink

Please sign in to leave a comment.