Sustainability Navigation

Circle2 cam going offline

Comments

8 comments

  • Anderson83

    So just an update - now the cam goes offline as soon as i manage to restart it and nothing works.

    0
    Comment actions Permalink
  • Anderson83
    It's been 2 days now that my Circle2 is not working and not a single reply from Logitech. Could someone actually do their job here?
    0
    Comment actions Permalink
  • Anderson83
    So after 2 days now my Circle2 appears to be in "privacy mode" and won't show up in the app even after troubleshooting and restarting. No real help from Logitech. Now i wish i ordered from Amazon instead from their own site so incould raise a dispute. This is horrendous user support on their end,
    0
    Comment actions Permalink
  • Anderson83

    Got my Circle2 on Monday, now it's Thursday and it's as good as dead. The ring LED (when it bothers to start) is yellow and no amount of restarting, troubleshooting, rekiggubg works. All i received from Logitech is on mail more than 24hrs ago asking me about the status of the LED and that's it.

     

    This is abysmal behaviour for a company that sold me a 229chf paperweight. Unless i get an answer by tomorrow, i am requesting a refund and i suggest everyone else who's had this experience do the same.

    0
    Comment actions Permalink
  • HAKjar

    This may be too late to help you but I found that by calling the Logitech Circle 2 Support line directly, I was quickly connected to a very knowledgeable support person. It was far more useful than the email support path.

     

    Good luck.

    0
    Comment actions Permalink
  • wolfgang1603
    I have same problem. Can I give the cam back????
    0
    Comment actions Permalink
  • B-DK8404

    I just bought 2 circle2 cameras for a month ago...

    And they keep going offline, so i looked at google for any fix, and ended up here.

     

    Nearly a year later than this post was written and same problem occurs..

     

    Is there a solution or not?

    0
    Comment actions Permalink
  • Yuka6489

    I too am having the same issue of connection dropping constantly. It didn't do that before. Since the recent web update, it keeps dropping. Also some issues with the time stamp as well. When I scroll up to view a older time stamp, the newer time stamps keep flickering making it impossible to click on anymore. I have no option but to click on LIVE only. Such a problem to keep buffering the stream. I have very fast internet connection and also have 5 bars on the camera so it's not my connection.

    0
    Comment actions Permalink

Please sign in to leave a comment.