Sustainability Navigation

Circle 2 won’t reset or connect to network

Comments

14 comments

  • J.N.1554

    Same problem here!

     

    My circle2 stopped working. It went offline and I can’t get it online again.

    The LED ring is slowly blinking yellow/amber and doesn’t react to anything.

    Resetting don’t work. It eventually will blink green and magenta. But after releasing the reset button, it will go back to yellow blinking.

    I spend already 2 hours to fix it, but no result. The camera is only a few months old.

     

    0
    Comment actions Permalink
  • Ellen3620

    I have a similar problem but don't have as much knowledge as you do...don't even know where the reset button is. I am going to try to find the manual but I thought this would be simple!

    I unplugged one of the two cameras that were plugged in, just to move it and now they are both offline.

    I hope someone checks in and helps both of us soon!!

     

     

    0
    Comment actions Permalink
  • J.N.1554

    There is a reset button on the side (opposite side of speaker). You have to push this (hard) and hold for like 9 seconds. The LED will now change colors and you can release when the leds are blinking magenta and green. But this does nothing unfortunately.

     

    Lets hope they reply soon.

    0
    Comment actions Permalink
  • Ellen3620

    J.N. 1554 Hello, thanks for that help. I held the tiny raised circle for 9 seconds and the color changed to magenta then stopped! You made me laugh at least! Are you in Europe? You are about 5 hours ahead of my time.

     

    So, we wait. I wrote an email but why is there no phone # and no humans?? :)

    0
    Comment actions Permalink
  • josh5894

    I am having this same exact issue. I changed my wifi network and needed to update it on the camera. I can reset if I push very hard and wait nine second but then the unit just slowly blinks yellow for eternity.

    0
    Comment actions Permalink
  • Sunil7604

    Same problem for me. My circle2 stopped working. It went offline and I can’t get it online again. The LED ring is slowly blinking yellow and doesn’t react to anything.

     

    Resetting on the camera by holding the reset button. It eventually will blink green and magenta. But after releasing the reset button, it will go back to yellow blinking.

     

    I also tried removing the camera from the App for reset but now the App doesn't find the camera when I try to add it again.

     

    So now I don't have the camera on the App and the camera itself just blinks yellow.

     

    0
    Comment actions Permalink
  • Christopher1616

    Just had the same problem. Camera went offline and I couldn't re-connect. Followed the advice above, pressed reset for 9 seconds. Magenta light came on. Switched off power and started set up again and got re connected

    0
    Comment actions Permalink
  • Kyle9080

    Same here... Any help logitech???

    0
    Comment actions Permalink
  • Lucanaut

    Unfortunately, I found this thread for the exact same reason. I have tried resetting the camera multiple times, holding the button until magenta/green flashes, but rather than the blue ring, it goes back to the yellow/white flashing. I even removed the camera element from the mount, unplugged it etc. Nothing seems to work.

    0
    Comment actions Permalink
  • markllam6744

    same problem here. went offline for no apparent reason and have done everything to try and get it working but no luck. not sure what to do now other than replace the camera having cancelled my storage subscription ;-(

    0
    Comment actions Permalink
  • Jerry Burt

    And another frustrated new user! Set up & worked fine; next morning, “offline” in both Logi app + Apple HomeKit. Purely the yellow ring; reset does nothing. Reset every possibility, including wi-fi, app & HomeKit, nothing works. Looks like it’s a refund & find a replacement that actually works. 😞

    0
    Comment actions Permalink
  • markllam6744

    My suggestion is to contact Logitech circle support direct. They agreed I had tried all possible fixes. Sent me an email to share with the retailer and request an exchange under the manufacturers warranty which I think is two years even if mine was less than 1 year old.

    ?

    Amazon have shipped my replacement as is their excellent service ?

    0
    Comment actions Permalink
  • J.N.1554

    Update from my side.

    I had contact with Logitech as well and they shared same answer to me as to markllam. I returned the camera and got my money back.

    In the mean time i bought a second Logitech camera (at a different reseller) and this one had the same issue after 1 month. Also yellow ring and nothing seems to fix it. I have contacted the reseller again and i will get it repaird or my money back. But i am quite done with this product.

    0
    Comment actions Permalink
  • Jerry Burt

    Seconded to 👍🏻 Amazon: online tech support tried (by suggesting all the possible remedies I’d already tried) to help; return label created & replacement on its way! Don’t imagine this will fare much better but always willing to give another chance....Seems they either work really well or not at all!

    0
    Comment actions Permalink

Please sign in to leave a comment.