Sustainability Navigation

Update to accessing Harmony Hub’s local API via XMPP

Comments

40 comments

  • user1013

    Hi, i am having issues finding my hubs using Home Assistant (Hassio). I have tried all the steps including clearing data and cache on my android phone and also restarted the hubs. The only thing remaining is factory reset which I am hoping not to perform. Any ideas why Home Assistant is not able to find my hubs? Any help would be appreciated. Thanks.

    0
    Comment actions Permalink
  • Debmoor

    I'm not familiar with Home Assistant, I use Homebridge.

     

    As @Frank Thompson?  said the update changed some identifiers in the hub making it look like a new device. This resulted in duplicate switches in my Homekit home app and a second hub in the iOS harmony app.

     

    So if you have turned XMPP on my suggestion is look at your Home Assistant configuration.

    Does it auto discover hubs? or do you have to enter it into a configuration file. Either way try removing existing settings to let it rediscover.

    0
    Comment actions Permalink
  • user1013

    Hi, I was able to get help from Home Assistant community to fix the issue. Nothing to do with Harmony update, just some workaround needed from Home Assistant stand point. For anyone else with the same issue, please see the below thread. Thanks.

     

    https://community.home-assistant.io/t/harmony-hub-issues-after-february-2019-update-v-4-15-250/100418/7

     

    But, THANK YOU HARMONY team for adding the option to enable XMPP, definitely shows that you listed to the community and take correct actions. I almost sold my 4 remotes to start using Xiaomi IR remote when the XMPP was permanently disabled.

    0
    Comment actions Permalink
  • comtech

    Unfortunately not working here. If XMPP activated or not makes no difference. Sync from remote and iPhone App to hub, reboot hub. All Homekit scenes not working since update to 250 F/W. Had it manually reset to 210 in december. Worked like a charm since then. Now all scenes are visible without errors in Homekit but not responding at all.

    0
    Comment actions Permalink
  • Debmoor

    As mentioned in previous posts on here Logitech have changed identifiers in the hub with this update which makes it look like a new device.

     

    You don't state what your method of making it Homekit capable is so we can not make suggestions on how to fix it

    0
    Comment actions Permalink
  • comtech

    I‘m using Homebridge running in a docker container. What I just found out is that there were several Harmony scenes (switches) in homekit not assigned to a room. All these scenes are listed twice as some users already posted. They even do work. Now I just need to find out how to make Homekit forget the non working switches.

    0
    Comment actions Permalink
  • joegr

    @Andreas Maier?  as several keep saying, the hub ID changed when it updated to .250. The non-working ones are the old hub (prior ID), and the working ones are the new hub (new ID).

    0
    Comment actions Permalink
  • Debmoor

    As I said in a previous post delete the contents of the accessories and persist folders then restart Homebridge.

    0
    Comment actions Permalink
  • comtech

    Thanks for the tip. Did that last night and restarted the Homebridge container. It is up and running now without any errors. But now all Homebridge functions in Homekit are dead. It woldn't be such a problem if I only had my 10 harmony switches in there. But I'm also running my complete "homematic" homeautomation setup running in in homekit with around 40 sensors, switches and lights, and several automation settings in that same homebridge container. It took me hours to set that up about a year ago and all these setting unfortunately can't be saved in Apple Homekit. So I guess I can start from scratch now just because Logitech thought messing with their firmware is a good idea 😖

    0
    Comment actions Permalink
  • Schorsch7695

    Thanks for adding XMPP API back again!

    0
    Comment actions Permalink

Please sign in to leave a comment.