Sustainability Navigation

MX Keys issue with Amazon Music Windows 10

Answered

Comments

4 comments

  • Thomas Wright

    I have figured this one out myself.

    I edited the Logitech Options settings file for the MX keys directly to add in the correct keystrokes to rewind/skip tracks, located at %appdata%\Logishrd\LogiOptions\devices\6b35b\6b35b.xml in windows. Not sure if there'll be different device names for other people, so check %appdata%\Logishrd\LogiOptions\devices\ and find an XML file which contains name="MX Keys Wireless Keyboard" on line 2.

    I had to manually set the key values to the standard media key values found at https://keycode.info/

    I set the Previous track to key "177", Next track set to key "176", and Play/Pause to key "179". Check for the IDs 0x00e4, 0x00e5, and 0x00e6.

    I found it easiest to remap the 3 media keys to something random so that the XML file was already set up to remap the keys. Then I entered the values 177, 176, and 179 as the remap values.

    I then had to go back into Options, set a totally different key (like volume up) to another keystroke, and then set that back to its default, so that the whole set of keystrokes are uploaded to the keyboard. Now my media keys work again!

    See the XML I edited below:

    <controlid rawxy="0" id="0x00e4" reprogrammable="true" type="fkey" fpos="8" taskidlist="previousTrackTaskIdlist">
    <task id="0x10000" class="virtualkey">
    <params alt="0" configure="1" ctrl="0" extkey="0" shift="0" vkey="177" win="0" />
    </task>
    <remappableids />
    <actions />
    </controlid>
    <controlid rawxy="0" id="0x00e5" reprogrammable="true" type="fkey" fpos="9" taskidlist="playpauseTrackTaskIdlist">
    <task id="0x10000" class="virtualkey">
    <params alt="0" configure="1" ctrl="0" extkey="0" shift="0" vkey="179" win="0" />
    </task>
    <remappableids />
    <actions />
    </controlid>
    <controlid rawxy="0" id="0x00e6" reprogrammable="true" type="fkey" fpos="10" taskidlist="nextTrackTaskIdlist">
    <task id="0x10000" class="virtualkey">
    <params alt="0" configure="1" ctrl="0" extkey="0" shift="0" vkey="176" win="0" />
    </task>
    <remappableids />
    <actions />
    </controlid>

    3
    Comment actions Permalink
  • Justin Wright

    Thanks to Thomas, I've found a slightly easier way to apply this fix for my MX Keys. I cannot guarantee it will work for all people or use cases.

    I noticed that a couple hardware function specific buttons were still working for my laptop (brightness up and down) and each of those XML elements had this 'divert' attribute set to 0 (probably false). By simply adding this attribute to the 3 media key elements and then restarting the Logitech Options software, it seems to fix the issue for me and prevents the Logitech Options software from swallowing up the key events.

    Those entries in my XML file now look like this:


    3
    Comment actions Permalink
  • 王沛文

    Justin's method is worked for my MX Keys. but it seems not work for my MX Ergo.

    0
    Comment actions Permalink
  • Thomas Wright

    Thanks Justin, I've found that my MX keys now "just works" with Amazon music. So I'm assuming they updated the application to listen for the correct keystrokes now!

    A benefit is that leaving the keys on the default means that they also work with other universal pause/next/previous apps such as YouTube in chrome while it's in the background.

    0
    Comment actions Permalink

Please sign in to leave a comment.