Sustainability Navigation

Logitech Group crashes Microsoft Teams on Mac

Comments

36 comments

  • Magnus Olsson

    We have the same issue. But it takes one and a half minute before it starts working. What version are you on? Mac OS and Teams Client versions?

    0
    Comment actions Permalink
  • Andrew Robinson

    Hi Magnus, maybe it is about a minute and half.

    We have a variety of Mac versions Mojave and Catalina. Our Teams clients are always up to date, currently running 1.2.00.28258

    0
    Comment actions Permalink
  • Magnus Olsson

    We clocked it and it’s about 1 minute 20 seconds. We also have a mix. Did you find any other posts on other forums yet? Hopefully there is a fix coming because something is broken after a update of either Mac OS or Teams app.

    0
    Comment actions Permalink
  • Andrew Robinson

    I have not found anything yet. I have tried to update firmware on the devices. We have 3 of them in total and is doing it on all 3 of them. Not great as we use Teams for all our internal meetings.

    0
    Comment actions Permalink
  • Magnus Olsson

    We have the same (latest) version of Teams, released 10/22

    0
    Comment actions Permalink
  • Magnus Olsson

    Same here and I had the same issue on devices with older firmware (now updated to latest).

    0
    Comment actions Permalink
  • Magnus Olsson

    Hi we solved it temporary by overwriting the app with an older version. Working as before with 1.2.00.3961

    1
    Comment actions Permalink
  • Magnus Olsson

    You can download other versions by editing the version number in the link

    0
    Comment actions Permalink
  • Andrew Robinson

    Anyone got any solution to this or can think of some suggestions to try. Its still happening across the board for every user.

    0
    Comment actions Permalink
  • Terry Lewis

    Have either of you had any further updates on this? I didn't find anything yet from Microsoft or even Mac yet regarding it.

    0
    Comment actions Permalink
  • Caps

    We recently tried to update to the latest version of Teams (1.2.00.34155) - They same issue still remains!

    Our Logi Group systems also got a firmware update recently.

    We need to get a solution for this. I can't believe how little I've heard about this problem, yet so many are affected by this.

     

    1
    Comment actions Permalink
  • Magnus Olsson

    Hi, first we solved it temporary by downgrading. This fix still works. However Teams auto-updates. So, after a while it is broken again. At first it looked like it was working after the autoupdate but then it was broken again. Yesterday we tried the latest version of Teams. Still broken.

    1
    Comment actions Permalink
  • Alan Lau

    same issue here - effectively all our conference rooms are down. @Logitech, any updates as to what might be broken? 

     

    0
    Comment actions Permalink
  • Terry Lewis

    We're working with Microsoft Teams and Logitech support currently. No fix yet though. I'll update this thread if we find a solution.

    1
    Comment actions Permalink
  • Alan Lau

    @terry and @logitech, We'd also have a ticket opened with Microsoft, if it helps this is our ticket number Ticket #:18010486, and it sounds like they might have identified the problem. Maybe reference that ticket number so they don't have to do twice the work.

    2
    Comment actions Permalink
  • Alan Lau

    We'd also have a ticket opened with Logitech too, ticket number 2081231. though Logitech support is absolutely useless.

    First, when I mention this thread, the support person said just downgrade as this thread suggests.

    Then they effectively refused to help to state it's a Microsoft problem as other apps (zoom and others) worked. I pointed out they are "certified" for Teams and now they are dragging their feet asking how many Mac is involved despite this thread shows at least others are having issues as well.

    Logitech if you guys are reading this - this is very disappointing at least take some initiative to show that you guys actually care. 

    2
    Comment actions Permalink
  • Chris Blättermann

    We're facing the exact same issues. Whenever we plug in the Logitech Group system into our Macs (which run macOS 10.15.2), Teams freezes entirely. We started debugging this by checking the firmware and even the Firmware Updater provided by Logitech crashes with a Segmentation Fault when the Logitech Group system gets connected. This leads me to believe that this indeed is primarily a Logitech issue and I would appreciate a fix for this.

    Now we found a workaround which works for us and is hopefully temporary: using Teams in Chrome. We are able to share presentations and browser tabs, but not the entire screen yet (which is a minor issue as we're mostly working with presentations and whatever we see in our browsers). Audio and video through Logitech Group also work good! However, sharing presentations/browser tabs and video at the same time does not work which appears to be a limitation of the web application of Teams.

    1
    Comment actions Permalink
  • Terry Lewis

    Its been two weeks and no further updates yet. Waiting on a response still from Logitech support.  Microsoft Teams engineer is also patiently waiting for us all to get on a call together. 

    I'll post an update if a solution is eventually found.

    2
    Comment actions Permalink
  • George Benitez

    Exact same boat, and Logitech says they can't recreate the issue on their end...

    0
    Comment actions Permalink
  • Magnus Olsson

    Hi, George Benitez and the rest of the thread, that sounds strange because the Swedish Logitech Support have confirmed that they can recreate the error and that they have have a dialoge with Microsoft and their Teams developers. I asked them several times to make a statement somewhere. My contact person at Logitech says he asked about this internally but nothing so far.

    0
    Comment actions Permalink
  • Chris Blättermann

    If helpful, I can also provide the crash report of the Logitech Firmware Updater.

    2
    Comment actions Permalink
  • Magnus Olsson

    The problem just got worse, after waiting 1 minute and 30 sec the app crashes. So the workaround of waiting is no longer working. Tested on a brand new Mac, latest version of Teams.

    0
    Comment actions Permalink
  • Andrew Robinson

    I took to YouTube to show what's going on.

     

    https://www.youtube.com/watch?v=7C99YUbyrh0

    3
    Comment actions Permalink
  • George Benitez

    Thanks Andrew, I'm sharing this on Logitech's twitter page, everyone else should do the same. @LogitechVC #MicrosoftTeams #Logitech

    1
    Comment actions Permalink
  • Marcus S

    Problem still exists with MS Teams 1.3.00.362 (from 20.01.2020).

    1
    Comment actions Permalink
  • Ulf Lundqvist

    We're having the exact same issues.

    1
    Comment actions Permalink
  • Stephan Heck

    same problem, very disappointing

    0
    Comment actions Permalink
  • 0
    Comment actions Permalink
  • Rasmus Knudsen

    We are also experiencing this challenge when connecting our MacBooks to Logitech Meetup and Rally.

    Teams version: 1.3.00.362

    MacOS: 10.15.3

    0
    Comment actions Permalink

Please sign in to leave a comment.