Sustainability Navigation

Logitech Harmony Remote Software (legacy software) for macOS 10.15

Pinned

Comments

76 comments

  • robindb

    Ok, good news I hope, downloading it now.

     

    How about Elite software ?

    0
    Comment actions Permalink
  • Manfred Hoss

    Sorry, but here the software is not function properly...

    Version 7.9.0.71, MacOS 10.15.1

    first Time Sync ok, but no second time....

    Now after klick on sync window blinks, ....in 15 Second etc. but nothing appear, connection not possible...this window was not there at the first time. Edit in the prog is ok, sync do not function.

    1
    Comment actions Permalink
  • phenoplastic

    System extensions? Really, no thanks. Thankfully I'm out of here, I sold my Harmony Elite and I'm loving my Sevenhugs Smart Remote.  Does everything I want and actually feels like it's been designed with a clear purpose and good user experience in mind.

     

    1
    Comment actions Permalink
  • dklj

    Paul I may headed the direction you took . . . . 

    MacBook Pro (15-inch, 2016). Mac OS Catalina 10.15.1 10.15.1 (19B88). Harmony 880.

    Downloaded and installed LHRS v. 7.9.0.71 successfully. Loditech.kext is in place I the ~/Library/Extensions folder. Connected the 880 and had to update the password before I could continue. Application (manually) starts up and correctly reads saved devices and activities.
     
    Will not sync.
     
    Sync window blinks this:
     
    None of the troubleshooting options resulted in a fix. Additionally the Application does not open automatically when the remote is connected.
     
    0
    Comment actions Permalink
  • Manfred Hoss

    I have a little workaround. Click on sync without remote connected. Then the normal window appear, then connect the remote. retry sync, sometimes it hang at 30%, next time it sync properly.

    0
    Comment actions Permalink
  • V O

    Glad to know that after years of promises and quite a bit of wishful thinking in several angry threads Logitech have finally managed to put together a buggy hack that can’t even use OSX features correctly. It sounds like 64 but support will be ready just in time it gets ditched by OSX in favour of 128 bit 😝

    Signed, a former customer.

    1
    Comment actions Permalink
  • Bob4079

    Seems to work for me, although I have not tried to sync my remote yet.  Installed fine, logged in fine, all my info seems to be there.  I for one am glad Logitech is finally fixing this issue for us Mac users.  Show a little gratitude, folks.  Easy to complain, but at least they are working on it!

    -1
    Comment actions Permalink
  • V O

    I’m sorry but time for gratitudes has run out several months ago. Now they are simply making a half-assed attempt to save the few remaining customers. Showing gratitude to a vendor for deciding to finally provide a tiny bit of service for the money they collected is just wrong. Vote with your feet. And $.

    Kudos to @wkwong, who’s seems to have been delegated as a scapegoat by Logitech, for taking the universal ire in stride. 👍🏻

    2
    Comment actions Permalink
  • Kevin Feeley

    I have a Harmony 660. The remote says USB connected, that is where it ends.  Nothing updates.

    0
    Comment actions Permalink
  • PKHarmony

    Kevin Feeley, 

    Can you please click the "Show Status" button on the Software and take a screenshot of the status and share here to troubleshoot further?

     

    1
    Comment actions Permalink
  • PKHarmony

    dklj,

    I'd recommend you to quit the software from the menu bar and try again. I hope this will resolve the issue, let me know the outcome!

    -1
    Comment actions Permalink
  • wkwong

    Hi dklj, 

    We recognize that screenshot, but it is not something that should be seen when using the latest app.  Are you able to reproduce that?  If so, can you send a screenshot that includes the URL bar?

    -1
    Comment actions Permalink
  • dklj

    wkwong and pkharmony:

    "I'd recommend you to quit the software from the menu bar and try again."

    I did. But before I read your reply I started in Safe Boot mode. LHRS v. 7.9.0.71 now works like the previous 32 bit version (s). Back ground maintenance starting in Safe Boot may have resolved my issue.

    One of the solutions offered was: 'Did the applications startup automatically when the remote was connected?'. System Report reports the 'Harmony' device is connected and drawing current. Remote reports 'connected'. But the application does not startup automatically. Easy work around. But should it?

    Thanks for your help . . . . 

    0
    Comment actions Permalink
  • uffe s

    Well, unfortunately as expected I completely fail. And it fails when I try to login... Using same login as before, but consistently fails. When trying to reset PW I am prompted to connect the remote, which fails consistently. So I would say this SW works like (usual Logitech) crap...

    4
    Comment actions Permalink
  • Deckard12

    Nice shitty software for a 250 euros remote control, dear Logitech. As expected, the app is a total fail. Again.

    3
    Comment actions Permalink
  • robindb

    So Logitech where is the Catalina software for the elite remote ?

    1
    Comment actions Permalink
  • Kalai

    Hi uffe s,

    Apologize for the trouble, please let us the know the Harmony remote model you are using and also let us know if you receive any error code or error message during the issue.

    @Georgios Sakkas,

    Apologize. Can you please mention the exact Harmony remote model you are using and provide more information regarding your issue, it will be helpful for us to troubleshoot your issue further.

    Thanks,

    Kay

    -1
    Comment actions Permalink
  • Deckard12

    Kalai

    Harmony Elite
    M/N: N-R0010, O-R0004

    Software installation: OK

    Log in: OK

    Besides the aforementioned, the software does not recognize the remote via USB, so no adjustments can be made.

    1
    Comment actions Permalink
  • urhlre

    I have a 650. The app starts, says it recognizes the remote,  then says I have to go to my harmony.com to create a new account and then nothing. Myharmony.com does not seem to have a way to create a new account, which I shouldn't need because this account seems to work.

    2
    Comment actions Permalink
  • wkwong

    Deckard12 This software does not support the Harmony Elite.  You should be using the Harmony App from your mobile device to create or access your Elite.  You can download the Harmony App from the Google Play Store or iTunes store.

     

    @Robert Lesser You currently have a MyHarmony account.  This software is also not for you.  You should be using Harmony Desktop.  From your computer, please go here - https://support.myharmony.com/en-us/download and click on the icon on the right.  After downloading and installing Harmony Desktop, you can log in using your email address.

     

    Thank you.

    0
    Comment actions Permalink
  • robindb

    wkwong

    When are we going to see the promised catalina Elite software ?

     

    This is well overdue.

    And saying to use mobile app is a non starter as per all the previous respondents on this.

     

    We spent a lot of money on the remote and now cant program it.

    2
    Comment actions Permalink
  • Dan Whitehead

    Unable to login using the correct email and password.

    2
    Comment actions Permalink
  • wkwong

    Hi Dan, 

     

    The software discussed here, Logitech Harmony Remote Software is for our legacy remotes.  

    You currently have a MyHarmony account.  This software is also not for you.  You should be using Harmony Desktop.  From your computer, please go here - https://support.myharmony.com/en-us/download and click on the icon on the right.  After downloading and installing Harmony Desktop, you can log in using your email address.

    -1
    Comment actions Permalink
  • robindb

    wkwong

    You miss the point, THERE IS NO CATALINA support for the elite remote.

     

    What are logitech doing about it ?

    2
    Comment actions Permalink
  • Dan Whitehead

    @wkwong, I have a Touch and an Elite.

    I know the Elite is not yet supported but thought the Touch might be?

    How do I fully uninstall this software then if it isn’t for my remotes?

    Can I also please ask, why you are developing software for Legacy models before your current range?

    1
    Comment actions Permalink
  • wkwong

    Hi Dan, 

     

    The Elite will require you to use the Harmony App from your mobile device.  The Touch, since it does not use a Hub, can be programmed using Harmony Desktop (not the legacy software discussed here).  Our legacy software support remotes like the Harmony 900, Harmony 1000, 1100.  

    It is a fair question to ask.  We worked on our legacy software to be 64-bit and compatible with Catalina because, without it, there will be no solution at all for those customers.  With our Hub remotes, there is the mobile app option, which is already used by many of our customers.  

    Thanks.

    ______

    To get Harmony Desktop:

    From your computer, please go here - https://support.myharmony.com/en-us/download and click on the icon on the right.  After downloading and installing Harmony Desktop, you can log in using your email address.

    0
    Comment actions Permalink
  • robindb

    wkwong

    PLEASE answer the question.

     

    when will the elite remote be supported on catalina ?

    1
    Comment actions Permalink
  • wkwong

    Hey Robin, 

     

    I don't have a good answer for you.  As of today, our Hub remotes are not supported on Catalina.  Account creation and access have to be done from the Harmony App from your Android or iOS device or from running MyHarmony on a Windows machine or a lower version of macOS.

     

     

     

     

     

    -1
    Comment actions Permalink
  • robindb

    Who responsible for this at logitech ?

    please provide contact details.

    1
    Comment actions Permalink
  • Steve Ascheman

    Quick question regarding the Logitech Harmony Remote Software (legacy software) for macOS 10.15.   Does that software already include Java within the app, or will it require the separate download and installation of Java8 from Oracle's website?  Your information about the software indicates it is now using the JavaFX engine, but I don't know if that means that Java is officially now bundled within your legacy software app or whether I'm going to need to download Java separately from Oracle when I get ready to transition to macOS 10.15 with my Logitech 1100 remote.

    0
    Comment actions Permalink

Please sign in to leave a comment.