Sustainability Navigation

Lag and stutter Mx Master 3 on new M1 MacBook Air Big Sur

Answered

Comments

49 comments

  • Official comment
    Bijit S

    Dear Jay, 

    Thanks for reaching out and sorry to hear about your experience with the MX Master 3 and M720 Triathlon Mouse. 

    Please try the steps shared in the links shared below: 

    1. Erratic cursor movement

    2. Mouse lag issue with Bluetooth

    3. Cleaning Logitech mice


    If the issue still persists post trying the troubleshooting steps, then please reach out to our Logitech support and we will be happy to address the concern. 

    Regards, 

    Bijit

    Comment actions Permalink
  • paul Grant

    im having the same problem , ive tried different mouses that work fine .. but my mx master 3 freezes all the time 

     

    i think that logitech has to improve there software to match Big Sur as ive down loaded the latest firm ware , that didn't work & the same on logitech options down load ,, still the same problem 

     

    let me know how you get on if you found a work around 

     

    thank u 

    paul 

     

    0
    Comment actions Permalink
  • VirgilBoy

    So far I am not seeing any lag/stutter on my M1 Mac Mini with my MX Master 3, happily. Using BlueTooth as well rather than dongle

    0
    Comment actions Permalink
  • Laszlo Laszlo

    Same problem here! I have random freezes + lost gesture function after 1-2 hours usage.

    Please update ASAP! 

    0
    Comment actions Permalink
  • Corporal Tunnel

    Hello. I think the issue is that the Logitech software isn't fully supported on the latest Mac platform (M1, Big Sur). I noticed that the Logitech Options software was updated yesterday:

    https://support.logi.com/hc/en-us/articles/360050549994-Download-Stub-MX-Master-3-for-Mac

    Does this mean that there is now native support for the mouse driver and application? The release document mentions Big Sur but there isn't enough detail for me to tell if the problems raised in this thread have been solved. I don't want to make a new purchase until I see confirmation that Logitech has addressed these Bluetooth performance issues in their software running on the latest Mac. Thank you.

    0
    Comment actions Permalink
  • paul Grant

    hi all 

    it was put to me that my device is faulty ,  ..possible ??? but i dont think so . what i noticed there was 2 or 3 blue tooth applications login onto my blue tooth with out my permission , with no name of the device but these random codes ,  i then realised the numbers was coming from the mouse it self ,...transmitting these random developer codes in stead of the name of the device .

    so i then realised i have the Logitech USB  unifying receiver , i then plugged that into my Imac and my MX master 3 mouse  worked perfectly no glitches ,no lag , no freeze .

     

    This left me with the only conclusion for my situation , there is a software issue with blue tooth 

     

    Thank u 

    0
    Comment actions Permalink
  • Corporal Tunnel

    Thanks for the update, Paul.

    I just tried to install that Logitech Options software I linked to in my last post. I got a warning saying Rosetta, the Intel Mac to M1 Mac compatibility software needs to be installed too. So I'm guessing native support still isn't included in that release and this issue hasn't been resolved.

    0
    Comment actions Permalink
  • paul Grant

    hi Corporal Tunnel   

    i had a email  back from logitech basically saying i need  reset my IMAC & Reinstall all software as this will clear out any bugs in my system .

     

    i chose not to do that ,as 1 my IMAC is not even 1year old & my mouse is 9 weeks old & have an anti virus software. 

    i simply stuck in my logitech unifying receiver & it works fine but not on blue tooth .. note apple are about to Drop Mac Os Big Sur 11.0.2 

    this may clear out any bugs 

    watch video link below 

    https://www.youtube.com/watch?v=AFZd6JQBYg4

     

    keep me posted on any changes 

     

    merry xmas 

     

    0
    Comment actions Permalink
  • Corporal Tunnel

    Hi Paul,

    I don't think resetting the Mac and reinstalling software will harm anything. I don't think it will fix the problem either. I've been reading other forum posts by people who are having Bluetooth issues with their M1 based Mac systems and it seems like the problem could be with Apple.

    Buggy MX Master 3 for Mac - on macOS Big Sur 11.0.1 – Logicool サポート + ダウンロード

    Maybe this issue won't be resolved until Apple updates their Bluetooth software on the M1 Macs and Logitech updates their drivers and software as well. I don't think the problem is faulty devices or broken systems. It's either a hardware or software design issue that should be solved with a software update soon.

    0
    Comment actions Permalink
  • Joe Dunbar

    I have a 2 and a 2S.  Had the same problem start for me a while back with my mid-2015 matchbook pro.  I recently bought a new MacBook Pro and have the same issue with both of them.  In addition, I have the matching keyboard that is also laggy and misses inputs.

    It is noticeably better when using the unifying rx connected via a direct USB adapter, but still problematic.  The new computer only has USB-C so I have to use an adapter but it's a 1:1 piece that is not doing any other work

    It's worth mentioning, you will almost always get optimal performance from using a USB dongle if a device comes with one. This is true of any wireless device with a USB dongle.  The reason it comes with a USB dongle in the first place, is because that is the recommended connection.  Bluetooth is garbage.

    Needless to say, I'm a bit disappointed and after having tried every possible suggestion and solution I could find, I'm about to move to the Kensington ball mouse.

    0
    Comment actions Permalink
  • Michael8067

    Just to let others know that this issue it is also problematic with Windows 10 pc.

    Even with the unifying receiver it works fine mostly, then all of a sudden lags and stick all over the desktop, and gets stuck on just about every icon in the program your working with, and even in File Explorer.

    This is the first time I have had any issues with any Logitech Gear - so I think MX 3 is just a dud.

    Gave up trying to sort it and went back to my G700 - problem gone. Very disappointed....

    1
    Comment actions Permalink
  • Riccardo Merlo

    Same here, unusable. Come on Logitech...

    0
    Comment actions Permalink
  • Eric Tristram

    Same issue, unusable on my Air M1. . :(
    But work perfecly on windows.

    Please...

    1
    Comment actions Permalink
  • Riccardo Merlo

    Last macOS update helps a lot but logo option is not Apple Silicon native, please Logitech hurry up.
    I’m planning otherwise to use USB OverDrive but one button is not recognized and I need all buttons

    2
    Comment actions Permalink
  • José Fernandes

    Extremely displeased with this.

    The mouse works perfectly over Bluetooth with an Intel Mac running Catalina I use for work.

    But both on a Macbook 12 2017 and a Macbook Air M1, both running Big Sur, it doesn't work properly. With the former is just unusable, the later displays intermittent lag, that it's not acceptable given the price tag.

    I don't know if the problem is with Big Sur, I just want it to work properly.

     

    1
    Comment actions Permalink
  • José Fernandes

    Is this going to be fixed? The odds of me ever spending a penny ever again, and I mean ever again, on a Logitech product are getting slim real fast.

     

    0
    Comment actions Permalink
  • VirgilBoy

    Have you tried to reset BlueTooth? Do you have a USB hub there...that may cause interference. Scroll down on that page to see how to reset BlueTooth.

    https://www.idownloadblog.com/2021/01/07/reset-bluetooth-mac-tutorial/ 

    -1
    Comment actions Permalink
  • ArtDirectionNeeded

    Chiming in here to say that I am also experiencing enormous lag spikes on Mac OS Big Sur / M1 Macbook Air with the MX Master 3. The lag occurs on bluetooth AND with the unifying receiver, while the receiver is connected to a USB-C hub. I have bought a small one-port USB-A to USB-C converter, and am testing it out. So far this fixes my problem, but is a major annoyance, since a major selling point of the MX Master 3 was avoiding dongles (The M1 Air only has two USB-C ports)

     

    I would appreciate any news on this issue - whose fault it is (Logitech or Apple), and what's being done to overcome this issue.

     

    Thanks!

    1
    Comment actions Permalink
  • Michael8067

    I am on a Windows machine, and I followed the steps in the 'Answer' for this thread, but that is NOT the answer, it is simply a problem with the MX Master 3.

    I actually bought another MX 3 thinking I just got a dud - it is marginally better , but as with the first one I bought, the unifying receiver looses connection. Putting it on a dongle so it is about 6 inches from the mouse works for the most part, but even then it will drop out now and then. 

    This is the only problem I have ever had with a Logitech device. I am disappointed with this product, and the advice from Logitech in some of the answers here (reset your system ^^ - lol) especially since I advocate to everyone to only get Logitech peripherals.

    Reverting back to my G700 sorts the issue. My advice is DO NOT get a MX Master 3 - it is a flawed device. Logitech should recall them, and revisit the design of this device.

    0
    Comment actions Permalink
  • Gabriel Camargo

    Same issue with my Macbook Pro m1. Mouse stutter, flow doesn't work. I have a new MX Keys and MX Master 3.

    0
    Comment actions Permalink
  • Riccardo Merlo

    The lastest version is still Intel and not Apple Silicon native!!!!!!!
    Sometimes lag spikes happens, IT NEEDS TO BE NATIVE!!!

    2
    Comment actions Permalink
  • ArtDirectionNeeded

    Update: I gave up and rma'ed the mouse. Running with an old 1st gen Apple mouse now. Still get stutters and lost connections. The problem seems to lie in Big Sur. Apple should be ALL OVER THIS!

    0
    Comment actions Permalink
  • Joe Dunbar

    I originally thought the problem was my environment and high levels of interference but both of my mice work perfectly with my windows machines (via bluetooth no less, not even using the dongle) so it does seem to be something between the mice and Apple products.  That being said, I'm on an intel Mac running Catalina and have had these issues for some time, so I doubt it's something specific to Big Sur.

    0
    Comment actions Permalink
  • Riccardo Merlo

    I've been using SteerMouse for few days and all the issue are gone for me. Anyway I wanted to use Logi Options since it is the official app, a new versione is out and it is still intel only.... that incredible.

    1
    Comment actions Permalink
  • Alexander Nizov

    Same problem, i use MBA m1 and MX Master 3 for Mac, freezes every 3 seconds since i opened new mac and connected mouse to absolutely clean system, install \ uninstall logitech options not helps.

    Hope that this issue gonna be resolved as soon as possible, but now i can't work with that.

    1
    Comment actions Permalink
  • Laszlo Laszlo

    Still have a problem here i can't work.....

    I bought magic mouse now and bye-bye logitech!.. Worst support ever with expensive price! Shame

    1
    Comment actions Permalink
  • Riccardo Merlo

    Yes Logitech support is terrible. Last updates are a step in the right direction but the driver is still Intel based even on Apple Silicon. This is no sense.

    0
    Comment actions Permalink
  • Willy Foo

    I thought Logitec would have updated to M1 silicon in a month... i was terribly wrong

    0
    Comment actions Permalink
  • Chingkhei Nganba2408

    Surprised that Logitech is slogging so much in producing an M1 silicon native Software.

    Regretting buying MX Master 3 couple of weeks back. Had I seen these conversation I would have bought some other Ergonomic Mouse or Trackball.

    0
    Comment actions Permalink
  • Prem L

    Hi Chingkhei,
    Thanks for reaching out.
    Please find the troubleshooting steps to resolve the issue:
    1. Please uninstall the Logi Options software and restart the system (mandatory).
    2. Using Rosetta, install the software using the link: https://support.logi.com/hc/articles/360025297893
    4. After installation, set the macOS permissions: Options & Permissions: https://support.logi.com/hc/articles/360023203954
    3. If the issue persists, create a new profile on the same computer or check with a different computer/device.


    Regards,
    Prem L
    Logi Support

    0
    Comment actions Permalink

Please sign in to leave a comment.