Sustainability Navigation

Logitech Flow is not working properly on Apple Silicon (M1)

Answered

Comments

74 comments

  • Official comment
    Jyothi Sequeira

    We'd love to keep the conversation going directly with the Support Team. So, I will now go ahead and create a new ticket for you.The team will review your case and will be in touch via email as soon as possible. Do not hesitate to let us know if you have any questions as the team follows up or in the meantime as the conversation continues there.

    Regards,
    Jyothi

    Comment actions Permalink
  • Carl Loop

    I have the same problem. PC to Mac is instant. Mac to PC is very difficult if/when it even works.

     

    3
    Comment actions Permalink
  • taro sansei

    I have the same problem. I am using MX Anywhere3 and MX Keys.

    2
    Comment actions Permalink
  • Nathan Weddle

    Same situation. MX Keys and MX Master 3 with Mac mini M1 and Dell Laptop. From PC to Mac is great. From Mac to PC is unreliable at best. Only very occasionally will it work the first time. It usually takes several attempts to get it to flow, if I don't give up and switch it manually. Using the "CTRL" key to edge of screen seems slightly better. Never seen the corner option work at all. Went through help doc to enable all the options for "Logi Options" and "Logi Options Daemon" in System preferences -> Security & Privacy. No impact on performance.

    2
    Comment actions Permalink
  • 태열 전

    I have the same problem. From Win10 to Macbook pro Bigsur is working well. But the reverse is not working. The logitech option app on Mac is not able to find the other computer. Sometimes the app can detect the computer when Wifi is turned off and on. But it quickly goes to disconnection.

    2
    Comment actions Permalink
  • Alishan Momin

    I have the same problem. Running Logitech options on M1 MacBook Air. Flow works from PC to Mac but not Mac to PC. Very frustrating as I bought the MX Master 3 for this reason alone. 

    2
    Comment actions Permalink
  • Guillermo Nadal

    I have been working with Logitech trying to solve this situation, but it was useless, nothing has changed.

    Just guessing but, Wouldn't it be necessary to review the Logi Options App and adapt it to the new Apple Silicon Processors?

    2
    Comment actions Permalink
  • Carl Loop

    I was told my ticket would be raised to Tier 2 and response would come in 24 to 48 hours. After 5 days, below was the latest "Tier 2" response they gave me. For me, is was very disappointing to get a laundry list of things to throw at the wall and see what sticks, very cookie cutter and general. I would think Tier 2 would have specifics. Seems like a brush off, but frustrating at the very least. My ticket is open more than 1 month now.

    Anyhow, that it might be of value, here is a link that shows the troubleshooting steps:

    https://support.logi.com/hc/en-us/articles/360023196954

     

     

    3
    Comment actions Permalink
  • Ramon de Klein

    Any update on this? Have tested it with numerous M1 Macs and it never works. It’s not a hard to reproduce scenario.

    2
    Comment actions Permalink
  • Alishan Momin

    Nope, it still doesn't work. I'm not sure how you can market a mouse "for Mac" and not even update the software to be compatible with most of the MacBook lineup. Pay $100+ for a premium mouse and its advertised features don't even work. This is a joke. 

    2
    Comment actions Permalink
  • 대한 정

    I bought Craft and mx master 3 for Logitech flow function. Paying $300, but coming back was a feature that didn't work as well as this post. If the function does not work properly, there is no reason to pay this much money. In other words, it was worth paying this much if it worked properly. When I looked it up, it was already said three months ago. A quick solution is needed. I think we should at least tell them the progress.

    2
    Comment actions Permalink
  • Ben Murphy

    Same exact issue for me. Flow worked fine between my 2020 iMac running Big Sur and my Windows 10 laptop. Got a new M1 mac Mini yesterday and now Flow only works going from the mac Mini to the PC, but cannot go from PC to the mac Mini. This is clearly an M1 issue. 

    1
    Comment actions Permalink
  • Roddy Markham

    Having this issue, which is very frustrating. I have the MX keys as well as the MX Master 3 Mouse - Can they update it so that when you change the connection on the keyboard the mouse automatically changes at the same time?

    6
    Comment actions Permalink
  • Ramon de Klein

    Roddy Markham I never understood why it isn't possible to link the mouse and keyboard this way. At first, I though I was doing something wrong, but then I found out that this functionality doesn't exist.

    2
    Comment actions Permalink
  • I_quacker_I

    Same issue for me, moving from M1 to PC flow just doesn't like it.  I have found that by clicking the mouse right before hitting the edge of screen will often trigger it to function correctly.  I have tried my best to explain this to support but they are just not listening.  I have also suggested exactly what Roddy Markham suggested above.  But this was brushed over.  How simple would this make things, particularly in my case as using three screens on my PC, a single button push to flip over to the M1 and back rather than scrolling all the way to find the edge to trigger the switch.  

    3
    Comment actions Permalink
  • Danny Ng

    I have the same issue with my newly purchased MX Master 3 for Mac and MX Keys. Besides this flow issue. I also experience scrolling issues when I'm on my Macbook Air with M1 but not as much on my windows 10 PC. 

    1
    Comment actions Permalink
  • Richdon Felipe

    I have the same issue. From PC to MBA M1, it works fine. but for MBA M1 to PC, it does not work. Any updates on this issue?

    1
    Comment actions Permalink
  • Mohammed Reza Alsabari

    Same issue, Works fine from my PC (running win 10 pro) to mac (mac mini m1), but not the other way around, using MX Master 3 mouse, other features works fine like copy & paste. I hope there will be a fix soon !.  

    1
    Comment actions Permalink
  • David Kemp

    I have this issue as well, exactly as described with my new M1 Mac Mini and a new build desktop with Windows 10. Windows to Mac fine but cannot move back to Windows, nor can I drag files. I bought this keyboard and mouse, MX, so I could just use the one between my two computers. I think the advertising of Flow is hugely misleading.

    1
    Comment actions Permalink
  • Parth Agrawal

    Facing the same issue while switching from M1 mac mini to windows laptop

    1
    Comment actions Permalink
  • Jia Mu

    I got the same issue. Moving the cursor form my win10 desktop to MBP M1 is really instant. But counterwise it doesn't work. I'm looking forward to getting your bug fix.

    1
    Comment actions Permalink
  • Richard van Breugel

    Same problem here :(

    1
    Comment actions Permalink
  • Richard van Breugel

    New update: Logitech options 8.50.210

    Testing...

    2
    Comment actions Permalink
  • Richard van Breugel

    Still does not work :(

     

    Idiots...

    4
    Comment actions Permalink
  • Reto9584

    same problem here with mac mini M1 and mbp intel, no connection between these two

     

    2
    Comment actions Permalink
  • Jia Mu

    There is curretly only a release on mac os to 8.50.210. But no release on win 10. The win 10 logi options remains in 8.36.86. The Problem is now worse. The problem was only the slow switching from mac to win10. Now if I change from win10 to mac, the process has become also very slow. I hope you can solve this problem as quickly as you can.

    1
    Comment actions Permalink
  • Jia Mu

    P.S: I have tried the automatically update in logi options in Win 10. There is no new update. And in some occation the mouse has changed back from mac to win, but keyboard not. I have to press the swtiching key on the keyboard again.

    1
    Comment actions Permalink
  • Mattias Karlberg

    Same issue here with win10 and Macbook pro M1...

    1
    Comment actions Permalink
  • Stephan Schmid

    Yep, can confirm it´s the same over here. The Software Version 8.50.210 did not solve the issue, same situation as before.

    1
    Comment actions Permalink
  • Matt Corman

    I'm having the same issue.  Mx Master2s, K780, M1 MB Pro.  Inconsistent from Mac to PC, PC to Mac works as expected.

    1
    Comment actions Permalink

Please sign in to leave a comment.