Sustainability Navigation

C920S doesn't always work on Zoom (Mac)

Answered

Comments

4 comments

  • Official comment
    Amogha A
    Hi Lydia,

    Thanks for reaching out. Please try the below steps to troubleshoot the issue:

    On Zoom, you can try this:

    -Launch Zoom and join a meeting/test meeting.
     
    -Ensure that the video button says """"Start Video"""" and is marked with a red line through it (meaning you aren't sharing your webcam)
     
    -Now, please launch Logitech Capture and it should pick up your C920s, as no other programs are currently using it as a source.
     
    -Click the little arrow included next to the """"Start Video"""" button, and kindly select Logitech Capture so that it has a check mark next to it, rather than the C920sitself.
     
    -Click on start video. You should have Logitech Capture running in the background, and can use it to make settings changes, design changes, and control the camera's basic functions, like zooming in. 

    We can select Logitech capture as a source only in Skype classic and its not available in any other skype versions.

    In case you need any additional support, please write back to us.

    Regards,
    Amogha A
    Logi Support
    Comment actions Permalink
  • Lydia Han

    Thank you Amogha, that did the trick. So it sounds like I always need to have Logi Capture running in the background for me to be able to use it on Zoom consistently. Is that correct?

    0
    Comment actions Permalink
  • Saurav T

    Hi Lydia,

    Thanks for reaching out.

    Yes, Logitech capture should be running in the background.

    In case if you need any additional support, please write back to us.

    Regards,
    Saurav T
    Logi Support

    0
    Comment actions Permalink
  • Thangam S

    Hi Rayn,

    Glad to know that the issue has been resolved.

    Please do not hesitate to reach out to us for any further assistance. We would be more than happy to assist you anytime.

    Regards,
    Thangam
    Logi Support

    0
    Comment actions Permalink

Please sign in to leave a comment.