Sustainability Navigation

MX Keys Screenshot button not working

Answered

Comments

5 comments

  • Official comment
    Prem L

    Hey Isaac,

    Thanks for reaching out.

    Please find the steps/link below to resolve the issue:

    Feel free to skip the steps that are already performed.

    To reset a Logitech Keyboard which uses Unifying or Bluetooth technology, please follow the below instructions.

    Turn off and on the keyboard
    Press the following key combinations - Esc+O Esc+O & Esc+B
    All Easy-Switch lights will blink continuously, wait for channel 1 to fast blink.
    Turn off and on the keyboard to complete the reset process
    If the Easy-Switch does not blink, please repeat the above steps again

    Pair the Keyboard with Unifying Receiver using the Unifying software or Pair the keyboard using Bluetooth

    Let us know if you have any questions or concerns at any time in the future.

     

    Regards,
    Prem L
    Logi Support

    Comment actions Permalink
  • Isaac Vasquez

    I tried it a couple of times and it still doesn't work. When I press and hold the screenshot button, the mouse does flicker but there is no action. No screenshots are saved to my documents either. 

    0
    Comment actions Permalink
  • Prem L

    Hey Isaac,

    Thanks for following up on the case.

    If channel 1 is not blinking, please skip to the next steps and proceed further.

    Regarding the Screen Capture, please use the key combination, Opt|Start + Camera Key (upper right corner of the MX Keys keyboard). That creates screenshots and nothing will appear on the screen, but once you go into your folders, it will appear under your Quick Access/Screenshot folder.

    Let us know if the issue persists so that we can assist you further.

    Regards,
    Prem L
    Logi Support

    0
    Comment actions Permalink
  • Isaac Vasquez

    I still can't get it to how it was before. But I was able to assign a keystroke that lets me do do a screenshot. 

    I'll keep on using it this way, thanks for your help! 

    0
    Comment actions Permalink
  • Prem L

    Hey Isaac,

    Thanks for following up on the case.

    We would like to inform you that the Camera key should work without any key combination.

    After pressing the key, we have to paste the screenshotted picture using "Paste" or Ctrl+V on a word document.

    Please check if assigning the keystroke using Logi Options and change the settings back to default helps.

    Please feel free to contact Logi Support at support.logi.com if the issue persists.

     

    Regards,

    Prem L
    Logi Support

    0
    Comment actions Permalink

Please sign in to leave a comment.