Sustainability Navigation

Why is there no Brio 4K support for Windows 11 after almost a year?

Answered

Comments

3 comments

  • Official comment
    Pooja B

    Hi Daniel,

    You can try the following steps. It might be that the USB drivers are installed with an error and thus the camera does not pop-up as a connected USB device and/or there is no video:
     
    Open Device Manager — go to the Start menu in Windows 10 and type “Device Manager” in the text box.
    In Device Manager, check the Imaging Device section — if you see a yellow exclamation next to the device name or the device name shows UNKNOWN, then the drivers did not load properly.
    To correct the issue:
    In Device Manager, right-click on BRIO/UNKNOWN device with the yellow exclamation icon, and select Update Driver.
    In the Update dialog, select Update Driver.
    Select Let me pick from a list of available drivers on my computer.
    Check Show compatible hardware (if not checked), then select USB Video Device (not Logitech BRIO), from the list.
    Click Next.
    NOTE: If a list of categories is shown instead, select Imaging Devices, then USB Video Device

    Regards,
    Pooja
    Logi support 

    Comment actions Permalink
  • Michael Barnes

    Pooja,

    In my case the Brio 4k Pro Webcam  will function normally on WIN11 startup (Version 21H2).  After startup the camera stalls and is no longer available, either in the Logitune App or Logitech Camera Settings.  If Windows is locked Hello no longer detects the camera and a PIN login is required.

    If the USB cable is moved to a different USB port, Windows will re-recognize the Brio and it will function during that session, but once the system is restarted the issue returns.


    ALSO, in Device Manager Logitec BRIO appears without issue under "Imaging Devices" when it is functioning.  After it stalls (after new bootup and hello login) it no longer appears under Imaging Devices at all.

    UPDATE:

    In addition, after the successful starup Hello login, at the end of the boot sequence there is a Windows Alert / Notice that pops up indicating that the last USB device attached was not recognized and installation has failed, followed by some indicator that the device has failed.

    0
    Comment actions Permalink
  • VASANTH J

    Hi Michael,

    Thanks for reaching out. We would suggest you try the steps below:

    Disable and Enable Webcam-
    Disabling and enabling the webcam device has worked out for many users facing similar issues.
    1. Press Windows key+R to open Run window.
    2. To open the utility, type or copy-paste this code and then hit Enter.
    Device Manager window will be opened.
    3. In Device Manager window, expand “Cameras” to see the available camera devices.
    4. Right-click on “Integrated Webcam” and click on “Disable device“.
    6. Right-click on “Integrated Webcam” and then click on “Enable device“.
    Reboot your computer.
    Note: – On some Computers the webcam / camera is under imaging devices.
    In that case just locate Imaging devices. Double click on imaging devices.
    Just Right Click and Disable and then right click and enable the webcam .
    After rebooting your computer you will be able to sign in with Windows 10 Hello Face.
    Fix 2 – Reinstall Webcam in device manager
    Disabling and enabling the webcam device has worked out for many users facing similar issues.
    1. Press Windows key+R to open Run window.
    2. To open the utility, type or copy-paste this code and then hit Enter.
    Device Manager window will be opened.
    3. In Device Manager window, expand “Cameras” to see the available camera devices.
    4. Right-click on “Integrated Webcam” and click on Uninstall.
    5. Now, Click on Action and then click on Scan for hardware changes.
    Fix-3 Uninstall camera driver and reboot
    1. You can access the Run window, press Windows key+R.
    2. Now, type “devmgmt.msc” and hit Enter.
    Device Manager utility will open up.
    3. Now, Expand system devices.
    4. Now, Right-click and Uninstall Surface Camera Windows Hello
    5. Reboot your PC.
    Fix-4 Turn Biometrics ON (For Windows Pro users Only)
    1. Press Windows key + R together from the keyboard.
    2. Now, write gpedit.msc in it and click on to open Local Group Policy Editor.
    3. Now, Go to Windows Components.
    4. Then, Click on Biometrics.
    5. Then, Click on Allow the use of Biometrics.

    You can use the below link which will help to fix the issue: https://support.logi.com/hc/articles/360023354673

    In case you need any additional support, please write back to us.

    Regards,
    Vasanth
    Logi Support.

    0
    Comment actions Permalink

Please sign in to leave a comment.