Sustainability Navigation

Google Meet fails to start HD Pro Webcam C920, Zoom works just fine

Answered

Comments

5 comments

  • Official comment
    Mohammad Ayub

    Hello Michael,

    Thank you for contacting Logi support. ​Meet needs permission to use your camera and microphone in Chrome. You will be asked to allow access the first time you join a Meet video meeting.

    You can change the setting to allow Meet to use your camera and microphone, click on the camera icon in the address bar, and select the Always allow option. 

    Let us know if you have other questions.

    Regards,
    Mohammad Ayub 
    Logi support

    Comment actions Permalink
  • Michael Gethen

    Thank you Mohammad, I appreciate your prompt reply! I forgot to mention in my first post, I have indeed also done the permission thing in Chrome, it still doesn't work. Note again that audio IS working, so clearly there is system connections working.

    0
    Comment actions Permalink
  • Michael Gethen

    0
    Comment actions Permalink
  • Michael Gethen

    Okay, an update. If I open Logi Capture first and have it in the background, then I select Logi Capture as the the camera in the Google Meet settings, it works. But with everything else closed (inc. Logi Capture), if I select the C920 as the camera option, then it fails to start.

    Note, in Zoom I can select the C920 without needing to have Logi Capture open, and it works fine.

    0
    Comment actions Permalink
  • Mohammad Ayub

    Hi Michael,

    Thank you for writing back. Please check if other applications using the camera are closed and end all the running applications from Task manager if in Windows.
    Make sure that you are using the latest version of Google Meet and try on a different system and let us know if you are facing the same issue.

    Regards,
    Mohammad Ayub 
    Logi Support 

    0
    Comment actions Permalink

Please sign in to leave a comment.