Sustainability Navigation

Craft Keyboard - Volume Sticking Goes to Max/Min

Commenti

24 commenti

  • DimitarC

    Hi - same issue here, no solution yet. I am hoping for a software patch soon as it is annoying (I am using the latest firmware). Also my keyboard keeps disconnecting from the PC although it is 30cm from the receiver - it's like it is loosing the connection for 5-10 seconds and then it works again.

    0
    Azioni per commenti Permalink
  • MarkWilson1782

    I have the same problem. I'm using the Craft keyboard with Windows 10 Pro on a Dell XPS 8700, the volume suddenly went to 100. Luckily my speakers have a manual volume knob or I would have had to 'crash' my computer. I installed the Logitech software update and it happened again yesterday.

    0
    Azioni per commenti Permalink
  • dncr

    Exactly same thing happens to me as well not constantly but every now and then it happens. I always follow the common IT rule "have you tried to turning it off and on again" which sometimes it doesn't resolve the issue but then I follow the same IT rule again. I see no answer in here about fix or any help offering from Logitech end.

    0
    Azioni per commenti Permalink
  • Steve_H

    I was having the same problem, until I completely uninstalled the Options software. Now the keyboard works great! I no longer have the crown "features", but I never used them anyway. The crown now acts as a volume control, and I no longer have that annoying volume notification box. The problem is definitely with the Options software and for the price of this keyboard, it is completely unacceptable that Logitech refuse to fix it!

    0
    Azioni per commenti Permalink
  • matarua

    Hi, I am having the same issue and it's incredibly frustrating with this 'premium' keyboard having issues like this. Contacting Logitech support is an even bigger nightmare. Turning off the software is not an option for my creative workflow. So is there any advice from anybody on how to fix this? Logitech?

    0
    Azioni per commenti Permalink
  • johnnny83

    Same here on a brand new Dell XPS 8930 with Win 10 Pro... Not only doesn't it stop, during that time the task bar is not accessible.

    0
    Azioni per commenti Permalink
  • Matthijs9127

    I also have the same problem. Using the Craft keyboard with Windows 10 and the Logitech Options software. The volume plus- and minus-buttons 'hang' when you press them once causing the volume suddenly to go to maximum (100) or minimum (0). The only thing that helps to regain control to the volume when this happens, is to switch the keyboard off and on again.

    Very frustrating. And potentially this problem could cause damage to my speakers when connected to an amplifier, if the volume of the input signal suddenly rises to 100.

    Please fix this Logitech!

    0
    Azioni per commenti Permalink
  • JosephYoon

    Same here with my XPS 8930 desktop and up-to-date Windows 10. It should be a software problem that Logitech can fix it, and they're too lazy.

    0
    Azioni per commenti Permalink
  • matarua

    Sick of waiting for a solution to this, here is what I have done.

    1. Turned off those keys in the software so they are not active
    2. Disabled all interactive functions for the crown so it's just a volume, play pause control in all apps
    3. Lost crown control of apps but didn't use it for the purpose anyway
    4. Re-trained my muscle memory to use the crown now for volume
    5. It works in different apps - but if you have say Spotify playing and something over the top of that then it will lower the music rather than say browser sounds.

     

    I had no luck trying to contact support on this it just sends me in an endless loop of re-selecting my product.

    0
    Azioni per commenti Permalink
  • dncr

    Hey Guys who posted here,

     

    I will keep spamming tweets till they fix it, please join me.

     

    https://twitter.com/Dincherince/status/1097259598325665792

     

    KR

     

    Dincer

    0
    Azioni per commenti Permalink
  • Ed8884

    ?never notice this problem, but i use Voicemeeter to control the knob

    This all with Logitech Options

    0
    Azioni per commenti Permalink
  • Jason96606669

    The temporary solution: Turn off the keyboard and turn it back on so you can control the volume again. Yes, it's annoying, especially for such a high-end keyboard. I am very disappointed but I've spent the money on it...

    0
    Azioni per commenti Permalink
  • johnnny83

    Guys, I think I have a solution. On my Win 10 system I have a bug which always resets system sounds to 50% (this bug is quite common if you google, only that it resets to 100% at other people). Apparently this is because system sounds are managed my the Windows Experience Host, which has no toggle in the standard volume mixer. In most cases you can fix this by installing EarTrumpet an extended volume mixer. The side effect: since I installed EarTrumpet the knob hasn't shown the bug anymore.

    0
    Azioni per commenti Permalink
  • alessandrobullo

    I have the same problem.

    It's terribly annoying!! It forces me to always pay attention when I turn up or down the volume and I need to turn the keyboard off and on to regain control of the level.

    Incredible that a fix hasn't been yet released.

    0
    Azioni per commenti Permalink
  • johnnny83

    I have EarTrumpet installed for three months now and during this time the annoying behavior only occured once.

    0
    Azioni per commenti Permalink
  • alessandrobullo

    Thank you very much @Johny Varsami?! I didn't know about the existence of this App.

    I try it immediately and I will also post my response in a few months.

    0
    Azioni per commenti Permalink
  • alessandrobullo

    Even after installing EarTrumpet, the problem reoccurs occasionally, too frequently.

    Unfortunately I haven't solved with @Johny Varsami? suggested way.

     

    It's really frustrating. 😫

    I hope in a software fix by Logitech.

    0
    Azioni per commenti Permalink
  • Jin7032

    Same, it's still not fixed. Disappointed.

    0
    Azioni per commenti Permalink
  • Jimmy Kevic

    Still not fixed. Thinking about returning it since i bought it for just 2 weeks ago.. 

    0
    Azioni per commenti Permalink
  • DB610

    same problem - sucks when it happens

    0
    Azioni per commenti Permalink
  • Joseph Yu

    I used to own the Craft keyboard. I got so fed up with the problem that I decided to buy a brand new MX Keys Keyboard. After using it for a day or two, the same volume problems started happening. All the way up with up, all the way down with down. Only way to stop it is to turn off the keyboard. What a shame. I can't believe this unit still has good reviews if a lot of people are having this same problem.

    0
    Azioni per commenti Permalink
  • Daniel Ng

    I have the same problem and its very frustrating! can't seem to find a solution. And to think that this is a "PREMIUM' keyboard from 'REPUTABLE' brand! Amazed that this problem has been around for so long and they just can't be bothered to fix it! 

    0
    Azioni per commenti Permalink
  • Ed8884

    It must be something else what triggers that.

    It never happend with my keyboard.

    And i programmd my crown not only as volume knob but when i open a pdf it becomes my scroll knob.

    You could try it for a large pdf to. it must be scrolling ( without controlling it) down or up.

    Then you would know its a defect knob.

    Or 3th party software what triggers it. i dont use Spotify but i read in the past that there where diffuculties with that for example...

    0
    Azioni per commenti Permalink
  • Emila Lowas

    I tried the firmware replace and bluetooth settings on my pc. Keyboard still keeps sound asleep if I have not used it in what looks as if 20-30 seconds as you can read about it. Super irritating and makes it very tough to work with. When the keyboard does work it's far exquisite. Anyone have some other ideas or should I just go back it?

    0
    Azioni per commenti Permalink

Accedi per aggiungere un commento.