Sustainability Navigation

Yeti X unusable on macOS Big Sur on Apple Silicon / M1

已回答

评论

86 条评论

  • partyondudes

    Sneha D, thanks for reaching out. Please do pass it to the team and mark it as highest priority—we've been notifying you all of this significant issue via various channels for months without resolution! Our microphones are basically unusable right now. That's very disappointing given the high ratings that Blue/Logitech has historically received. You'll lose our business long term if this isn't resolved.

    5
    评论操作 固定链接
  • Sneha D

    Hi there, Sure, Let us know if there is anything else we can share with them or if you ever have any questions any time in the future. 

    2
    评论操作 固定链接
  • JerryInNYC

    To steer other M1-chip Mac owners away from the Blue Yeti X, I posted information about the problem in my review of Blue Yeti X on Amazon.

    https://www.amazon.com/review/R2WQVNRY8DG7X/ref=pe_1098610_137716200_cm_rv_eml_rv0_rv

    3
    评论操作 固定链接
  • Fiona Leung

    What is annoying is I actually was using the Yeti X and Blue Sherpa together and just loved how it sounds.  Now when I got the M1 which supposedly is for better performance, I cannot use it anymore.  I am still holding onto the Yeti X and I really really would like to see a fix soon so that everyone can use this great microphone again for what they love to do.  

    2
    评论操作 固定链接
  • Phillip Le-Roy

    After doing some searching I've found this article. It's really annoying that we can't use the microphone with the M1 MacBooks with BigSur. The workaround posted by George indeed works but we miss the whole functionality from the Blue Sherpa software. I hope this gets fixed soon.

    2
    评论操作 固定链接
  • Tim Davey

    George Jarrett your solution worked! Running the uninstall script alone didn't do it for me. So I had to manually move (as it's safer than removing) the extension file. Via below then restarting the machine.

    cd /Library/Extensions/; sudo mv logi_audio_override.kext backup_logi_audio_override.kext;

    I still can't use the software but at least I can now use the mic. Thank you!

    0
    评论操作 固定链接
  • Gerhard Wallnöfer

    Es gibt tatsächlich immer noch keine Lösung?? Ich kann es langsam echt nicht mehr fassen....

    1
    评论操作 固定链接
  • Phillip Le-Roy

    Logitech Team: do we have any news about this?

    4
    评论操作 固定链接
  • Mark Guldbrandsen

    6 months and still no fix? I regret buying the Yeti X now, it is kind of useless to me. Please give a update on when it will be fixed, otherwise I will need to find another mic soon. 

    4
    评论操作 固定链接
  • Yeti X needs updated

    Logitech this is such poor customer service and product support.

    The Blue Yeti X compatibility with M1 Mac needs to be addressed in a software update of Blue Sherpa and Logitech G Hub.

    You also need to inform customers when you expect this long over due update to be released. 

    5
    评论操作 固定链接
  • Gerhard Wallnöfer

    Is it possible to get an update of the process going on, if some process is going on....?

    1
    评论操作 固定链接
  • Sean Hamstra

    Same exact issue with Mac M1 and Yeti Nano. For me it "works" as a basic mic if I restart with it plugged in. If you unplug and plug back in OR start sherpa it reverts to the terrible echoing, unusable audio. Please fix and at least provide an update asap!

    0
    评论操作 固定链接
  • KAYHAN YILDIRIM

    I have the same issue. I have contacted Blue and they told me that it is Apple's fault and Apple has to fix it. I contacted Apple. And Apple said that it is Blue's fault and they need to fix it. 

    I am using a very expensive microphone without its perks when you do the reboot Mac with the Blue Yeti Nono plugged in. I am so frustrated. 

     

    Please fix it. It has been months...

    2
    评论操作 固定链接
  • Phillip Le-Roy

    I've raised a Support case for this subject and the response I had was similar to the official given here in this post:

    If you are on a Mac computer using an Apple Silicon M1 processor, please note that we are currently working on a fix.

    Please note management/development are aware of the issue and currently working on a fix. However we do not have a determined timeline as of yet unfortunately. Thank you for your patience.

    2
    评论操作 固定链接
  • JerryInNYC

    "Thank you for your patience"?

    Why is Logitech thanking us for our patience? 

    I'm not patient.

    I'm pissed. 

    Are you patient?

    1
    评论操作 固定链接
  • Phillip Le-Roy

    JerryInNYC, I completely agree with you. It's just ridiculous the amount of time to deliver software for the M1 chip.

    1
    评论操作 固定链接
  • VahransFire

    For what's worth, my G HUB software recently updated to version 2021.6.4851 and it seems to be working "better" now. I haven't been able to test outside of the built-in BlueVO!CE stuff, but the samples are clear and don't have any issues. Not sure if this is a fluke or an actual fix that's starting to roll out.

    1
    评论操作 固定链接
  • Ahmed A

    Hey there,

    We're so glad we were able to help! Let us know if you have any questions or concerns any time in the future.

    Regards,
    Ahmed A
    Logi G Support

    -2
    评论操作 固定链接
  • VahransFire

    Ahmed A I wouldn't take 1 report of what is at best partial success as a victory yet. I would still like confirmation that a fix was deployed in the software version I mentioned. Otherwise, this is possibly an anomaly. 

    3
    评论操作 固定链接
  • Philippe Chiu

    Just installed Logitech GHUB 2021.6.4851 and the issue is still there, more annoying than ever, given the  fact that Logitech is still not providing a solution while it has been clearly identified it's bound to its software (kernel extension) with M1 chips.

    0
    评论操作 固定链接
  • Robert Mohns

    Having similar problems with buzzing audio with the Yeti X on Big Sur on a 2016 MacBook Pro i7. Whatever the issue is, it's not just Apple Silicon. It's with Logitech G Hub itself.

    -1
    评论操作 固定链接
  • David Clement

    Anyone know if this has been resolved?

    0
    评论操作 固定链接
  • Juan María Sánchez Cruces

    Hi, I have a Yeti Nano and Blue Sherpa updates and stop working, pointing that from now on I need to use G-Hub, so I download it and never identify the mic. I have MacBook Pro 16 with Intel chip and G-Hub is not recognizing my Logitech gear. If this do not get fixed I will be selling everything and buying elgato and Corsair that al least woks on Mac.

    1
    评论操作 固定链接
  • Boji Lazov

    Just got my yeti x today and am having the same issue. So frustrating to see that it has been happening to people for 7 months without any action from Logitech. I will be returning the device and leaving a negative review due to the lack of action or urgency by Logitech.

    3
    评论操作 固定链接
  • griffdb

    I have the same issue with a Yeti X on both M1 and Intel Macs after getting the microphone on Tuesday.

    1
    评论操作 固定链接
  • Robert Mohns

    @Griffdb Return it while you still can. Logitech hasn’t fixed this in nearly a year, I don’t think they care.

    0
    评论操作 固定链接
  • Adam Bellas

    I agree with Robert Mohns, griffdb - return it. I'm well past the date for my YetiX. I'm a well rounded software and hardware professional in the IT industry, for decades, and I can't get this thing working on my M1 Big Sur MacMini. Logitech and Blue (same thing I guess) aren't giving us anything, not for months.

    Return it. Even if they come out with a fix tomorrow, they've lost my trust as a vendor in every way. The damage is irreparable. 

    0
    评论操作 固定链接
  • Luan Devecchi

    It is now working on my M1 Air. (Yeti Nano)

    Release notes: https://software.bluemic.com/blue/ReleaseNotes/
    > Added compatibility for macOS Big Sur for Apple Silicon.

    I'm using Logitech G Hub, firmware has been updated as soon as I opened the program today (2th aug).

    Edit:

    They now force you to use G Hub

    2
    评论操作 固定链接
  • Adam Bellas

    Confirmed: latest Logitech G Hub update seems to correct issue. Wow, they finally did it.

    Thank you, Luan Devecchi, for posting. I immediately updated to G Hub version 2021.8.792 and then opened Adobe Audition and made a recording. Initially, things look good. I've got more things to try, but it's looking good so far.

    To confirm: my Yeti X appears to be working properly on my MacMini running Big Sur on Apple Silicon now via Logitech G Hub version 2021.8.792.

    1
    评论操作 固定链接
  • Sean Hamstra

    I can confirm it finally works as well! Even the noise cancellation. (Blue VO!CE)

    Mac mini M1 with the Yeti Nano, GHUB version 2021.8.792

    1
    评论操作 固定链接

请先登录再写评论。