Sustainability Navigation

Yeti X unusable on macOS Big Sur on Apple Silicon / M1

已回答

评论

86 条评论

  • Mellow Now

    Guys...and Gals....

     

    Fix this kindly. Or the SM leverage is about to happen. 30 days should be enough?

    2
    评论操作 固定链接
  • Vida Bennett

    My problem is that I just updated from Big Sur 11.2.3 to 11.3, and now my Yeti is not working.  I've an intel processor.  I use the yeti to record online exercise classes, so I'm a bit stuffed now.  It worked perfectly on 11.2.3.  The workaround above - shutting down my Macbook Air, plugging in the yeti, then restarting the system has worked, but it's not ideal.

    Does anyone from Logitech even read these pages?  And how will we know when there's a fix?

    2
    评论操作 固定链接
  • Naiyana Phaodit

    I've message BlueMicrophones on instagram yesterday and their response is looking good.

    "We are currently investigating the compatibility issues. Please check back very soon for updates."

    I hope this helps and i hope they follow through because I love their products.

    2
    评论操作 固定链接
  • Sneha D

    Hi there, Sure, Let us know if there is anything else we can share with them or if you ever have any questions any time in the future. 

    2
    评论操作 固定链接
  • Fiona Leung

    What is annoying is I actually was using the Yeti X and Blue Sherpa together and just loved how it sounds.  Now when I got the M1 which supposedly is for better performance, I cannot use it anymore.  I am still holding onto the Yeti X and I really really would like to see a fix soon so that everyone can use this great microphone again for what they love to do.  

    2
    评论操作 固定链接
  • Phillip Le-Roy

    After doing some searching I've found this article. It's really annoying that we can't use the microphone with the M1 MacBooks with BigSur. The workaround posted by George indeed works but we miss the whole functionality from the Blue Sherpa software. I hope this gets fixed soon.

    2
    评论操作 固定链接
  • KAYHAN YILDIRIM

    I have the same issue. I have contacted Blue and they told me that it is Apple's fault and Apple has to fix it. I contacted Apple. And Apple said that it is Blue's fault and they need to fix it. 

    I am using a very expensive microphone without its perks when you do the reboot Mac with the Blue Yeti Nono plugged in. I am so frustrated. 

     

    Please fix it. It has been months...

    2
    评论操作 固定链接
  • Phillip Le-Roy

    I've raised a Support case for this subject and the response I had was similar to the official given here in this post:

    If you are on a Mac computer using an Apple Silicon M1 processor, please note that we are currently working on a fix.

    Please note management/development are aware of the issue and currently working on a fix. However we do not have a determined timeline as of yet unfortunately. Thank you for your patience.

    2
    评论操作 固定链接
  • Luan Devecchi

    It is now working on my M1 Air. (Yeti Nano)

    Release notes: https://software.bluemic.com/blue/ReleaseNotes/
    > Added compatibility for macOS Big Sur for Apple Silicon.

    I'm using Logitech G Hub, firmware has been updated as soon as I opened the program today (2th aug).

    Edit:

    They now force you to use G Hub

    2
    评论操作 固定链接
  • griffdb

    @Robert Mohns, I have both M1 and Intel-based Macs.  The biggest fix for me was:

    cd /Library/Extensions
    sudo rm logi_audio_override.kext

    For me, the Yeti X hardware is solid.  I just needed to delete the older kext file.

    But now, Logitech has updated Logitech G Hub; I installed that on both machines,  and that works as well.

    On my Intel Mac, on Big Sur 11.5.1, when I launch G hub, it still loops asking me to plugin and unplug my hardware.  But the mic works just fine.

    2
    评论操作 固定链接
  • Robert Mohns

    Thanks, griffdb! I'll give that a try. The kext appears to have been last updated yesterday, but I'm removing it and restarting to see how it goes…

    2
    评论操作 固定链接
  • Wilhelm Eek

    Also weighing in with similar issues with my Yeti X and 2019 Intel Mac.

    One thing I noticed is that the input delay increases almost as if there's a backlog of audio to process. 

    2
    评论操作 固定链接
  • Frenchie

    MacBook Pro (13-inch, M1, 2020)

    macOS Big Sur Version 11.6

    Yeti (Not Yeti X, or Yeti Nano)

    Logitech G HUB Version 2021.9.7463

     

    Experiencing input delay issue as well. Oddly, it was working well when first received.

    Looks like it'll have to be returned :(

     

    Tried every suggestion posted here, and across other sites. It would seem to be an audio processing issue.

    2
    评论操作 固定链接
  • Tom

    Yeti Nano. M1 Macbook.

    I work online, video conferencing. Have had it about 6 months working flawlessly (without installing any drivers) until....

    About a month ago, i foolishly installed the Sherpa software. Which then told me i need to install the G-Hub software. This caused all kinds of problems and the mic wouldn't link up with Skype nor Teams nor Zoom.

    So, uninstalled all the software, deleted and restarted. Now, in video calls, it will work for about one minute and then dies. 

    To conclude, don't ever install their software. Originally, the default mac driver worked. You could even unplug and replug without restarting. Now, it's horrific and the hardware has become useless due to amateur Logitech software engineers producing abysmal software and drivers. And not even offering a solution to download/find/return to the original default MacOS driver. 

    OR, it might be an issue with the firmware update.

    I can reset my mac. But it has taken an eternity to setup and register all my software, its licenses, etc. 

    2
    评论操作 固定链接
  • Tom

    Other solutions here haven't fixed it. However, this has:

    Step 1: Uninstall Sherpa and G-Hub completely

    Step 2: Remove the GHub plugin from Library/Audio/Plug-Ins/HAL

    Step 3: Remove logi_audio_override.kext from Library/Extensions (and/or backup_logi_override.kext)

    Step 4: Restart your Mac

    2
    评论操作 固定链接
  • Carlo Zayne

    I agree with Tom above. However, I found that if you use other Logitech products such as the G502 and G915 which requires G Hub, you do not have to uninstall G Hub itself. Just remove the drivers by following the commands below after installing G Hub.

    Open Terminal and run
        sudo rm -rf /Library/Extensions/logi_audio_override.kext
        sudo rm -rf /Library/Audio/Plug-Ins/HAL/LogiGamingAudio.*

    Reboot your machine and the Blue Yeti mic should work again. However, the Mic will not be recognized within G Hub and will throw an error (Please unplug and replug device) which you can ignore.

    2
    评论操作 固定链接
  • Shrivathsa

    Hi Jean,

    Thanks for following up. We'd love to help open a case to provide a solution directly over email. So we will now go ahead and create a ticket for you.

    Thanks so much, and looking forward to getting you in touch with the team.

    Regards,
    Shrivathsa
    Logi G Support.

    2
    评论操作 固定链接
  • Shrivathsa

    Hi George,

    Thanks for following up. We'd love to help open a case to provide a solution directly over email. So we will now go ahead and create a ticket for you.

    Thanks so much, and looking forward to getting you in touch with the team.

    Regards,
    Shrivathsa
    Logi G Support.

    2
    评论操作 固定链接
  • Greg Hadley

    Just wanted to pop in and say I'm having the same issues. When support reads this, please please please just send a note to whoever is incharge of ignoring users that they ******* suck, and that I regret buying any logitech product, and I will make a note to always vocalize how atrocious your software is.

    2
    评论操作 固定链接
  • Andre 9218

    Having the same issue as partyondudes it's a shame all of this.

    1
    评论操作 固定链接
  • Adam Bellas

    Also experiencing issues. MacMini, M1 chip, MacOS 11.2.3.

    Blue Sherpa can detect my YetiX, but only when connected directly to the machine (no hubs).

    Sherpa can live monitor the input levels and control mic functions, but when I choose Yeti as the output device for sound, I hear nothing from my headphones connected to the YetiX.

    All functions well on Windows 10, even through USB hubs, so I have a good control to judge by. Really need this to work on my MacMini. Strongly emphasizing a need for this fix.

    1
    评论操作 固定链接
  • Naiyana Phaodit

    Adam Bellas

    You, sir, have given me hope. 

    I've bought my Yeti X today and was wondering why it was not connecting to my 

    Mac air only to find out it's not compatible with Big Sur yet and was about to return it.

    I love how to mic sounds and hopefully they will fix it soon. Or I'll follow the others with returning/reselling.

    1
    评论操作 固定链接
  • Nam Ho

    For the love of god, please fix it. Is it a resource issue or software limitation? Or does someone need to own the roll out of this bug / feature?

    I’m happy to own this product. Point me towards your JD, I’ll apply, and land the gig just to get this fixed.

    I want my crispy HD voice on my meetings to flex to my other FAANGers.

    1
    评论操作 固定链接
  • Gerhard Wallnöfer

    Es gibt tatsächlich immer noch keine Lösung?? Ich kann es langsam echt nicht mehr fassen....

    1
    评论操作 固定链接
  • Gerhard Wallnöfer

    Is it possible to get an update of the process going on, if some process is going on....?

    1
    评论操作 固定链接
  • JerryInNYC

    "Thank you for your patience"?

    Why is Logitech thanking us for our patience? 

    I'm not patient.

    I'm pissed. 

    Are you patient?

    1
    评论操作 固定链接
  • Phillip Le-Roy

    JerryInNYC, I completely agree with you. It's just ridiculous the amount of time to deliver software for the M1 chip.

    1
    评论操作 固定链接
  • VahransFire

    For what's worth, my G HUB software recently updated to version 2021.6.4851 and it seems to be working "better" now. I haven't been able to test outside of the built-in BlueVO!CE stuff, but the samples are clear and don't have any issues. Not sure if this is a fluke or an actual fix that's starting to roll out.

    1
    评论操作 固定链接
  • Juan María Sánchez Cruces

    Hi, I have a Yeti Nano and Blue Sherpa updates and stop working, pointing that from now on I need to use G-Hub, so I download it and never identify the mic. I have MacBook Pro 16 with Intel chip and G-Hub is not recognizing my Logitech gear. If this do not get fixed I will be selling everything and buying elgato and Corsair that al least woks on Mac.

    1
    评论操作 固定链接
  • griffdb

    I have the same issue with a Yeti X on both M1 and Intel Macs after getting the microphone on Tuesday.

    1
    评论操作 固定链接

请先登录再写评论。